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Welcome to TopSolid 2022 

Throughout this document, you will discover the main enhancements and learn about the new features and benefits 
of the latest 2022 release of TopSolid 7. The innovations described here only represent a small portion of the new 
functionalities. 

If you are interested in finding out more about the newest TopSolid 2022 features, please contact your local reseller.  
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What’s New in TopSolid’Design 7.16 
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This section describes the enhancements made to the PDM, Design, Sheet Metal, Nesting, FEA, Drafting and 
Unfolding applications in version 7.16 of TopSolid 7. 

User Interface 

Compass 

The color of the compass axes has been changed to be consistent with other software on the market. Now, the X axis 
is displayed in red, the Y axis in green and the Z axis in blue. 
However, these colors can be modified in the Tools > Options > Colors > System colors section. 

 

Displaying parameters 

In the Operations tree, when a parameter is named, the type, name, value, expression and designation of the 
parameter are now displayed in the Definition node (as in the Entities tree). 

 

Manufacturing Features 

In order not to overload the display, the arrows have been removed. 
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Selection colors 

The selection colors accessible from Tools > Options > Colors > System colors have been slightly modified to be more 
contrasted. To apply this new setting, you have to click on the Reset button. 

 

Selection filter 

A dynamic selection filter that allows you to limit the drop-down list using a few entered characters has been added 
to the drop-down lists of the following commands: 

- Modeling > Extruded Bar (Assembly document) 

- Tools > Functions > Provide Function (Part and Assembly documents) 

- Tools > Material and coating (document Part) 

- Tools > Parts material and coating (Assembly document) 

 

Example of a filter when including an extruded bar. 
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Upgrade 

The Upgrade command is now available from a multi-selection from the Operations tree. This command allows you 
to replay an operation in the current version provided that the selected operations accept this command. 

Licenses management 

The new protection mode named CLS (Cloud Licensing System) allows you to simplify the license management. Users 
log in with an account (email address) and three types of licenses are available: 

- Standalone: The license is assigned on a protection key or unique identifier. 

- User: The license is assigned to a user identified by his email address. 

- Float: A number of licenses is allocated per company. Licenses can be taken from any location, making it easy 
to manage licenses from home, for example. 
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PDM 

Multiple exports 

From the Project Manager dialog box, the new Export Packages command allows you to export a selection of projects. 
This new command creates as many packages as selected projects. 

 

Libraries 

Protected (read-only) libraries are now identified by a specific icon with a key. 

 

Package import 

When importing a package, the new Forced Copy option allows you to import the documents by duplicating them. 
This new option will be particularly useful to solve index and/or version problems. 

Export for subcontracting 

When exporting a package, the new Export for delivery option allows you to generate a package whose elements will 
not be modifiable after import on another site (subcontractor site). 
To use these documents, you have to copy or derive them, which allows: 

- on the subcontractor's side, not to modify the originals; 

- on the customer side, to continue the modifications. 
This same mechanism must be used by the subcontractor to return his project to his customer. 
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On-the-fly referencing 

When a component is included from a library (or a project) that is not referenced by the project, TopSolid now offers 
to automatically reference this library. 

 

Connection 

The new PDM > Connection as command allows an administrator to login with another user's account without 
entering the password. This allows you, for example, to check the documents into the vault for a person who is absent 
(user having left the company, employee on leave, etc.). 

Displaying updates 

The update display mode has been identified as a factor that decreases performance: as a result, a warning message 
is now displayed when this mode is enabled. 
When the update display mode has been disabled, after modifying a document, the Update command should be used 
to display the list of documents to be updated. 
During a new installation, this mode is now disabled by default. 

 

Managing external documents  

When an external document (.docx, .xlsx, .txt, etc.) managed by the PDM is opened for modification and then saved 
in its application (Word, Excel, Notepad, etc.), it is now automatically saved in the PDM. 
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TopSolid'Pdm Explorer 

The administration Users, User groups, Security, Mail server, History, Default export path, Purge cache and Convert 
users commands have been added. They allow TopSolid to be administered using the TopSolid'Pdm Explorer thin 
client. 

 

TopSolid'Diagnostics 

A new TopSolid'Diagnostics application allows you to make a diagnosis (memory, disk, network, antivirus, etc.) of the 
machines (clients and servers) and to offer solutions when problems are detected. It is available in the program 
installation folder (by default in C:\Programs\TOPSOLID\TopSolid Diagnostics 7.16\bin\TopSolid.Diagnostics.exe). 
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Sketch 

Parabola and hyperbola 

Two new commands have been added to the 2D Sketch > Other Curves menu. They allow you to create parabola and 
hyperbolic arcs. 

Edge copy 

In a 3D sketch, the Edges Copy command with the Paths around faces option now has a Special inputs icon that allows 
you to select the edges of a part according to a root face, blend faces, faces by color, tangent faces, faces along edge 
paths. 

  
Example of edges copy with selection of tangent faces. 

Parallel drawn on-the-fly 

When creating a contour and/or a line, if the cursor is placed on another linear segment, TopSolid draws a magnetic 
axis parallel to the linear segment, passing through the last point of the contour being created. A dimension is created 
automatically if you base on this magnetic axis. 
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Contour 

A new Length field allows you to enter a value that will be assigned to the length of the created segment and the 
corresponding dimension will be automatically added. 

 

Rectangle 

With the Three points, by base mode, the new Height option now allows you to indicate a value (thickness) and to 
only give two construction points. 
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Fillet 

The 2D Sketch > Fillet command has a new option called Equality constraint for the Global and Internal external 
modes. This option allows you to create only one dimension and to add an equality constraint on each fillet. 

 

Trimming by dragging 

In the 2D Sketch > Trim command, you simply have to now click in the graphics area and to move the cursor (keeping 
the left button pressed) on the parts to be deleted in order to trim them. 

 

Cell 

The Explode contextual command allows you to split a cell type entity into four sketch segments in order to make 
modifications (fillets, chamfers, etc.). 

Half-part dimension 

The 2D Sketch > Revolution dimension command has been renamed 2D Sketch > Half Part Dimension. 
This new type of entity has three types of displays (half-part, large diameter, or whole part) that can be adjusted using 
the Display contextual command. This display mode will be used by the Detailing > Projected annotations command 
in a drafting document. 

Symbol copy  

Symbols, except for symbols with geometric drivers, can now be copied using the Ctrl + Drag technique. 
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Pixelating 

The new 2D Sketch > Operations > Profiles Batch > Pixelating command allows you to create a sketch and patterns 
from an image. These entities can be used, for example, to repeat drillings in order to reproduce the image on a sheet 
metal. 

 

 

Base image Perforated sheet metal plate made from the sketch generated by the 
pixelating operation. 

Options 

In the document options, several changes have been made to the Planar sketch and Spatial sketch options: 

- The Grid section has been renamed by Snap. 

- A new Grid section has been added in order to modify the default settings of the grid (Type, Coordinates, 
Step). 
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Shape 

Enclosing cylinder 

The calculation of the enclosing cylinder axis is now automatic. However, you can define the axis manually by checking 
the Orientation axis box and then selecting an axis. 

 

Drillings 

For blind drillings with a flat drill (smooth hole and counterbore), you can now add a bottom radius. This information 
can be retrieved from a table or a drilling dimension. 
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Draft 

The Step with plane option has been added to the Draft with step mode. It allows you to select a plane, which avoids 
imprinting an edge on the shape to be drafted. 

 
Example of a draft with step and plane selection. 

In addition, the Split faces option available in the Draft with reference plane and Draft with step modes allows you 
to either separate the faces located on each side of the reference plane or not. 

 
Example of a draft with split faces. 

Enclosing block 

Polyhedral shapes from an import (STL, FBX, etc.) are now compatible. 
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Surface 

Imprint by plane 

The By plane mode has been added, it allows you to imprint the intersection profiles between the part and the 
selected plane. In addition, the Faces option allows you to choose the faces on which the profiles will be imprinted. 

 

Pipe 

The Linear Variation option has been added to the Rotation and Scale dialog boxes. It allows the section to evolve 
either linearly or not along the path. 

  

Example of a pipe with scale and the Linear Variation box unchecked. Example of a pipe with scale and the Linear Variation box checked. 
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Marking 

The Marking dialog box has been modified: 

- Three icons allow you to choose the type of information to mark. 

- Arial, Calibri and IsonormD fonts have been added. 

- A section allowing you to orientate and position the text has been added. 

- You can define a specific machining process. 

 

 

   

The new dialog boxes of the marking command. 
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Sheet Metal 

Sheet metals recognition 

When recognizing Profile and Tube parts, the camera orientation is automatically adjusted to the orientation of the 
profile in the document. This improvement now allows you to create views in multiple draftings that are automatically 
oriented along the axes of the profiles. 

  

Recognition and conversion of parts into profiles, without 
modification of the camera. 

With the new version of TopSolid, the views are 
automatically oriented along the axes of the profiles. 

In addition, in the case of recognition of standardized profiles, the section type and its code are associated with it. 
And the corresponding parameters are created allowing you to format the designations of the profiles, for example. 

Sheet metal recognition processes 

In the Work document, a new Sheet metal recognition (TopSolid'Design) process is available. 
This process automates the creation of sheet metal parts, from part or assembly documents. 
The options for this process are similar to those available for the classic assembly document command. 
In the Results tab, only the documents modified by the conversion are listed. 

Performance improvement: Sheet metal properties computation  

A very important improvement regarding calculation time has been added when generating the sheet metal 
properties. This improvement is very significant in the case of parts with many bends and/or many holes. 

Conversion into unfoldings 

This contextual command, launched from the Project tree, allows you to manage Autocad imports containing multiple 
unfoldings in order to create unfolding documents for each identified part. 
You can now create the part document of the sheet metal for each unfolding. Therefore, the information only available 
on 3D parts, such as the MFs from the analysis operation, can be used for costing, for example. 

Unfolding and rebending of bend 

The unfolding and rebending of bend commands have been enhanced with a new Developable bend mode. They now 
allow you to unfold and rebend strictly developable surfaces, in particular the option can be applied to straight cones 
or inclined cones. 
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You can impose an unbending method, which is suitable for unrolling surfaces and therefore has the Approximation 
tolerance and k factor parameters (as in the Unbending Process command in Rolling mode). 
As for the classic unbending bends, you can perform Boolean operations (pockets, drillings, trimmings, etc.) or imprint 
operations on the unbended faces. The dimensions of the removals and imprints carried out before the rebending 
operation are kept, as well as their geometry. The drillings are identified as drillings in the drafting document (and 
therefore listed in the drilling tables). 

 

 

FreeShape 

Progress bar 

When extracting one or more drilling groups, a progress bar is now displayed at the bottom of the screen. 

Tapping standard 

In the FreeShape > Extract holes command, a new drop-down list allows you to choose the standard of the tapped 
hole. 
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Assembly 

Automatic positioning 

In the Constraint command, the absolute origin point, axes (X, Y and Z absolute), planes (XY, XZ and YZ absolute) and 
the absolute frame are now offered in the Destination field. 

 

Extruded bars 

Operations 

When a profile has operations other than cutting operations, it is now identified by a specific management operation 
in the Analysis step that produces an Operated = True parameter in the Parameters > System parameters folder 
located in the Entities tree. This parameter can then be retrieved in a bill of materials, allowing the user to create a 
more detailed drafting document of these profiles. 

 

In addition, the profiles derived for modification are now compatible with cutting operations (mitre trim, main trim, 
etc.). 

Possible lengths 

This improvement avoids you to create copies with lengths of 100m. TopSolid then uses the first possible value just 
above the actual length as the length. For example, when installing a profile on a 2.5m profile, if the possible values 
of 1m, 3m and 10m have been declared in the generic document, then the copy created will use the length 3m. This 
is very interesting when the profile generic contains a multitude of operations because the calculation time during the 
inclusion is considerably optimized. 
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Curved extruded bars 

As for the operated extruded bars, the curved extruded bars are now identified by a specific management operation 
in the Analysis stage which produces a Curved = True parameter in the Parameters > System parameters folder 
located in the Entities tree. This parameter can then be retrieved in a bill of materials, allowing the user to create a 
more detailed drafting document of these profiles. 

 

In addition, two improvements have been added: 

- Curved extruded bars are now compatible with the Mitre Trim command. 

- The curved extruded bars are divided into simple shapes (straight part, curved part), which allows them to be 
dimensioned in the drafting document. 

Profile of extruded bar 

In an assembly document, you can now include several extruded bars and provide the Extruded Bar function to define 
a profile of the extruded bars. This allows you, for example, to create a component consisting of an extruded bar and 
its joint. This profile of extruded bars behaves like any simple extruded bar and supports cutting operations (mitre 
trim, main trim, curved extruded bar, etc.). 

 

Distribution 

In a family document, the Distributable Family driving now offers an Angle parameter to manage the orientation of 
the distributed component. 
Therefore, in the distribution command, two modes are now available: 

- Normal orientation mode: the orientation of the component is perpendicular to the slope. 

- Vertical orientation mode: the orientation of the component is parallel to the vertical direction (Z axis). 
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Normal mode Vertical mode 

In addition, when distributing a component such as a railing on a staircase, the new First component centered option 
allows you to reposition the first component on the origin of the distribution. 

Local assembly 

When converting a part from a sub-assembly to a local part, the sub-assembly is converted to a local assembly and 
now a warning message is displayed to warn the user of this conversion. 

Locally modifiable parts 

The Modeling > Local shapes > Locally modifiable parts command has been added: when a part has been defined as 
locally modifiable, if an assembly operation (drilling, trimming or pocketing) is applied, it is generated only in the 
assembly. As a result, there is no synchronization between the documents. This operation is automatically launched 
when the parts are connected (see also the Tools > Joined parts paragraph). 

In-place part 

In the options of a Part document, the General > Default commands for part in place option allows you to choose the 
commands to be launched when creating an in-place part. You can choose a command to select a planar face, a sketch 
or when no selection is active. 
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Building 

Multi-flight staircase 

TopSolid'Building now integrates the Multi-flight staircase command. This command allows you to calculate a 
staircase distribution according to many criteria. 

Key features: 

- two laying methods: 

 

 

By table  
(entry of the values of the different flights) 

By points 
(direct installation on environment) 

- two calculation methods: 

  

Same rise 
Straight steps have the same rise but different runs 

Same step 
Straight steps are completely identical 

- three methods of angle management: 

 

  

Landing Spiral treads Winder treads 
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- four possible results: 

 

   

Sketch on the ground Profile on each step 3D Shapes Component (family) 

- five applicable constraints (min, max, objective): 
o Rise; 
o Run; 
o Treading angle; 
o Treading step; 
o Number of treads. 

 

Family 

Parameter 

The tree structure of the parameters folder is now retrieved in the Generics folder of the Family document.  

Driver update 

When including a family, the drivers can now be updated manually. For families containing many drivers, this allows 
the component to be updated only when all drivers have been completed. 
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Bill of Materials 

Grouping 

When defining a column, the Allow grouping and Allow subtotal options allow you to group the parts with the same 
property and to count them. 
In the drafting document, these groupings and subtotals can be displayed by checking the Visible options of the new 
Bill of material section available in the Detailing > Bill of Material Table command. 

 

In the Columns command, the properties are now offered in the tree form and a search field makes it easier to choose 
the properties to be displayed. 

 

This feature is also available in a filter and search document. 
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Calculated column 

When defining a column, the Add option allows you to perform an operation (simple or complex) from the contents 
of the existing columns. Two types of formula are available: 

- Text: allows you to "add" the content of several columns (example: Material + Coating). 

- Numerical: allows you to make a calculation between several columns (example: Length x Quantity). 
The principle of the calculation formulas is identical to that of creating a parameter. 

 
Example of a column calculating the total mass (unit mass multiplied by the number of parts). 

Parameter from project 

All the project parameters can now be retrieved in a BOM column. 
To do this, you simply have to create a relay parameter (for example, a text relay parameter) in each part or assembly 
document that retrieves the desired parameter. 

 

Visualization 

Camera from a frame 

The new Visualization > Cameras > Standard cameras management command allows you to redefine the orientation 
of standard cameras from a frame. 
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Studio document 

The new Studio document has been added to the Advanced tab of the document creation dialog box. This type of 
document has a Ground entity by default and allows you to position a part or an assembly document, to define an 
environment, light sources and cameras in order to calculate an image. 
The main advantage of this type of document is that you can change the material and coating of the parts without 
checking them out of the vault. For this purpose, the Parts Material and Coating and Face Coating Management 
commands are available in the Tools menu. 

Physically Based Rendering (PBR) material and coating 

You can now define PBR materials or coatings. They are defined by their albedo, roughness, metallicity, normal, 
opacity, transmission glossiness, ambient occlusion and transmission scattering. Each feature (available as a 
category) is defined by a Texture document. 
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Moreover, a graph editor allows you to adjust some parameters of the different features in order to add more 
granularity to a material for example. 

 

Example of adding noise to a texture. 

 

  

Basic texture Result 

Rendering camera 

The new Visualization > Rendering Camera command allows you to create a conical camera by indicating the position 
of the eye, the point of view, the type of lens and the features of the image to be calculated (size, rendering scale). 
This type of camera also allows you to use a 2D background image to superimpose a 3D design. 
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Rendering style and post-processing style 

The Rendering Style and Post-Processing Style commands have been added to the Visualization menu. They allow 
you to predefine styles that can then be used when calculating an image in realistic rendering. 

Realistic rendering 

The Realistic Rendering dialogue box has been modified: 

- The preview dialog box is displayed as soon as the command is launched. 

- The command can be launched using the R shortcut key. 

- The Styles tab has been added, it allows you to choose the rendering camera, the rendering style and the 
post-processing style. 

- In the Post-Processing tab, the Denoise option has been added. It allows to remove the noise caused by the 
lighting and to perform a kind of "smoothing". 

 

Example of an image without the Denoise option. 
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Example of an image with the Denoise option. 
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Analysis 

Geometry analysis 

In non-automatic mode, the Point, Axis and Plane modes now allow you to create entities on-the-fly. 

Analysis 

The details of the MFs as well as the annotations (tolerancing, roughness, etc.) are now displayed on the label. 

 
 

Construction 

Point clouds 

When selecting a plane cloud, the Search planes contextual command has been renamed Search geometries. It can 
now be used to search for planes, cylinders, axes or frames. 
In addition, the Edit the point cloud contextual command allows you to delete, separate or add a batch of points from 
the cloud. 

Copying and pasting parameters 

You can now copy and paste the parameters from one document to another, whether they are in the same project or 
not. 
The Copy command is available either by right-clicking on the selected parameters or from the Parameters folder (in 
this case, all parameters are copied). 

 
  



What’s New in TopSolid’Design 7.16  TopSolid 2022 

32   TopSolid 

Nesting 

Document preview 

In order to make the preview of a nesting document more readable, especially in case of many supports, the preview 
is now automatically created in top view instead of perspective view. 
In addition, you can configure the appearance of this preview in a nesting template document via the new File > 
Document Preview command. 

  

Preview of a nesting document in 7.15. Preview of the same document in 7.16. 

Performance improvement 

An important improvement regarding calculation time has been added to the nesting document. This improvement is 
very visible in the case of parts with many faces and/or many holes. 
The improvement deals with the opening time of a nesting document and the nesting calculation. 

Automatic nesting 

Increasing check options 

Many checkings have been added, blocking the creation of an automatic nesting in case of problems. 
- Verification of the documents to be nested: the thickness and material compatibility between parts and 

supports is verified. 
- Verification of the documents generated by the nesting: for example, for the Sheet Metal Cam documents, 

we check if there is a template document and if it has a machine. 
- In Sheet Metal Cam, flip is not possible. An error message is displayed on the part line if the flip is selected. 

Manufacturing index 

If the nesting is created from a bill of materials exposing the Manufacturing index column, these are now correctly 
associated with the parts in the nesting document, as in the parts of the assembly documents produced by the nesting. 
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Large priority parts 

A new Large priority parts option in automatic nesting allows you to calculate the priority of the parts to be positioned 
from the largest to the smallest enclosing box in the Parts tab. 

 
In this example, the priorities are added manually: Yellow 1, pink 2, blue 3, purple 4 part. 

Not all the purple parts could be positioned. 

 
In this second example, the priorities are added automatically in order of size. All the purple parts are first positioned, then the 

blue ones in the remaining space, then the pink ones, and finally the yellow ones. 

Maximum number of part references by support 

This new option available in the Strategy tab consists of imposing a maximum number of part references per support 
to help and therefore save time in unloading the batches of parts corresponding to a command, for example. 

 

In this example, no limitation of part references is added. 

 

In this second example, a maximum of two part references are allowed per support. 
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Nesting tab in the nesting results display panel 

The Nesting tab, only available before via automatic nesting editing, is now displayed in the results tab. 
From this tab, you can open each of the documents produced by the nesting. 

 

Empty supports 

You can now create a manual nesting part, in empty supports. This command allows you to choose the desired 
support, as well as the desired nesting verification options. 

Manual nesting: Dynamic control of the position 

A new Dynamic control of the position option allows you to choose to check for collisions with parts already 
positioned in the support either: 

- Dynamically: the part preview is only visible if you can position the part. 
- Non-dynamically: the part preview is always visible at the “end" of the mouse. The verification is only done 

on click. 

In the latter case: 
- If you can position the part, the move or copy modifications are made. 
- If you are outside of the support or if the position is not valid (no place available on the support or too far 

from a valid position), nothing happens. 
- If you are close to a valid position, the parts are positioned at the nearest valid position. 

Nesting process 

In the Work document, a general Nesting (TopSolid’Design) process for the parts is available. The process is available 
with the Imbrication license. 
This process automates the creation of nesting documents, by creating automatic nestings from part, unfolding or bill 
of materials documents. 
The process groups the parts/unfolding by compatible materials/thickness and will produce as many nesting 
documents as groupings found. 
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Tube Nesting 

Automatic tube nesting: Partial common cut 

In the Strategy tab of the tube nesting, you can now define the matching criteria for partial common cuts thanks to 
the two added parameters: 

- Minimum length proportion per part: each portion in common cut must cover at least x% of the perimeter  
- Minimum length proportion: the total length in common cut must cover at least x% of the perimeter 

These values are given in percentage. 

Nesting from a bill of materials 

You can now add the parts list with the relative quantities of parts. 
You can also change the quantities of the parts with an overall multiplicity of the assembly. 

 

Bar Nesting 

Automatic bar nesting 

This new command allows you to nest profiles in a support bar of the same section type. After defining the profile 
nesting characteristics, for both profiles and support bars, the parts will be automatically positioned on the bars to 
optimize the overall loss rate of the bar required to nest all the parts. 

 

In this first version of the command, it is the profile enclosing boxes that are nested, without management of the 
possible flips and/or cutting angles. 

Profile nesting characteristics: part as a support  

A new Usable as support option allows you to define a profile family as nesting part and as support. 
Thanks to this new option, you no longer have to duplicate the family and its generic to identify the supports. In 
addition, the type of profile to be nested is now defined by its possible degrees of freedom in rotation, and no longer 
by a type of section. 

Bar nesting process 

In the Work document, a Nesting (TopSolid'Design) process for profiles is available. 
This process automates the creation of nesting documents, by creating automatic bar nesting from part or bill of 
material documents. 
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Tools 

Mirror from a document 

The new Tools > Mirror Definition command allows you to define a document as a mirror of another document. This 
command will be mostly used when importing a right-hand part and its left-hand part. 

Enclosing block 

The Enclosing block command has been added to the Tools menu. As in a part document, it allows you to calculate 
the enclosing box of a representation of the assembly. 

Joined parts 

The new Tools > Joined Parts command is used to declare parts as glued or welded. When including a sub-assembly 
containing joined parts, if an assembly operation (drilling, trimming or pocketing) is applied, the shapes are made 
modifiable automatically and the operations on shapes are only generated in the assembly. As a result, there is no 
synchronization between the documents. 

Derivation 

When deriving a document, you can now derive Directions entities. 

 

The annotations created in the document as well as the imported annotations can be derived by editing the 
Annotations Management operation (or the Imported Annotations Management operation) and checking the Derive 
box. 

 

Publishing 

The Publish Block Envelope command has been added to the Tools > Publishings menu. This avoids, for example, 
publishing the six planes of the block envelope. 

Level reference 

The new Tools > Annotations > Level References Management command allows you to define the reference of 
heights (NGF and Project) of a part or an assembly from a frame or an IFC file. This reference will be used when 
creating a level note (see also the Drafting > Level note paragraph). 
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Contouring MF 

The Tools > Contouring MF command has been added. It allows the machining to be prepared for TopSolid'Cam by 
indicating a frame and possibly a machining process. 

 

Online help 

From now on, the online help is also published on the Internet, which makes it possible to update without waiting for 
the release of a service pack. For users who do not have access to the Internet, the local version is always available in 
the TopSolid installation folder and the Tools > Options > General section allows you to choose to display either the 
local or the online version. 

 

 

TopSolid'Fea 

Selection 

The root face selection option has been added to the Uniform Pressure, Surface Load and Hydrostatic Pressure 
commands. 
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Drafting 

Draft bundle 

In a draft bundle, when performing automatic nesting, the Nest one drafting by page option allows you to 
automatically create a new page for each plane of the nesting. 

 

Dimensioning 

When selecting a toleranced hole, the Tolerances section now offers an option to automatically display this tolerance 
as it appears in the 3D document. 
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In the Format section of the dimensioning dialogue box, the new Overlaid texts font size factor option allows you to 
assign a scale factor to the height defined in the tolerance font. 

 

In all the fields allowing you enter a text in a dimension or a dimension style, the " + " button now displays a selection 
panel of the usual symbols. For other symbols, this panel also offers access to the symbols in the Windows special 
characters table. 
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Automatic dimensions 

The Detailing > Automatic Dimensions command has been enriched to better manage the dimensioning of the 
profiles. 
The Length Dimensions section allows you to add only one length dimension corresponding to the length of the profile 
before cut. 
The Cut dimensions section allows you to either enable the length and/or angle dimensions or not. 

 

In addition, imported profiles (using the recognition option) as well as derived profiles are now compatible with the 
automatic dimensioning. 

Automatic composite dimension 

The new Detection > Take side axes into account option available in the Detailing > Automatic composite dimensions 
command now allows you to detect drillings not represented by a circle. However, you have to create the automatic 
axes on the view beforehand. 

 

In addition, the Continue Mode has been separated from the other modes, it can now be combined with any one of 
them. When two modes are combined, the Distance in multiple mode advanced option allows you to manage the 
distance between the dimension lines. If the distance is zero, the two dimension lines are superimposed. 
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For more complex parts, the Continue per side option has been added in the Continue Mode section, it allows you to 
create the dimensions in relation to the sides of the part. 
In addition, the Detection and Advanced Options sections have been enhanced with new options: 

Detection: 

- Cylindrical face detection: allows you to take into account drillings, circular pockets, etc. 

- Vertices detection: allows you to take into account the vertices of the segments of the view. 

Advanced options: 

- Use auxiliary axes for isolated geometries: This option creates axes near isolated geometries (closed 
geometries included in the external contour of the part) on which the dimensions of these geometries will be 
hooked. 

This option has two sub-options: 

o Group isolated geometries: This option allows you to offset the dimensions on the main axis when there 
are no overlapping dimensions. 

o Use two axes for isolated geometries: This option allows you to distribute the dimensions on each side 
of the isolated geometry. 

 
Example of automatic dimensioning on a profile. 

Projected annotations 

Half part dimensions are now available in the Detailing > Projected Annotations command. 
The type of dimensioning depends on the display mode (half part, large diameter or whole part) defined in the 3D 
document using the Display contextual command on a half part dimension. 

 

Example of projected annotations with half-part dimensions. 
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Drilling table 

In the Detailing > Drilling table command, when the As table box is unchecked, the new Take side drillings into 
account option allows you to detect side drillings (not represented by a circle). Unlike automatic composite 
dimensions, you can create the automatic axes on the view beforehand. 

 

Drilling note 

When creating a drilling note or a drilling note style, you can now choose to display: 

- the diameter effective value (Nominal, Minimum, Average, Maximum or Automatic); 

- quality symbol; 

- tolerances; 

- effective value symbol. 

 

Example of drilling notes displaying the tolerances of the 3D document. 
The same style allows you to create the two drilling notes. 
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Level note 

The new Detailing > Level Note command allows you to identify the different altitudes of a part or an assembly. The 
height reference can be defined either locally in the drafting document or by using the Tools > Annotations > Level 
References Management command available in a part or assembly document. 

 

Editing the detailing 

In the Tools > Options > Drafting section, you can now choose the action to be performed when you double-click on 
a view. You can either edit the view (default) or edit the view's detailing. 

 



What’s New in TopSolid’Design 7.16  TopSolid 2022 

44   TopSolid 

Tables 

The content of the headers of the automatically generated tables (BOM table, drilling tables, etc.) can now be modified 
and the Rotate command is also available. 

 

When defining the columns of a BOM, you can now define a column on which TopSolid will apply a grouping and possibly 
to create the subtotal of certain properties. 

 

Example of definition of BOM columns with subtotal. 
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In the drafting document, the new Bill of Materials section in the Detailing > Bill of Material Table command allows 
you to choose the display of groupings and sub-totals. 

 

Bill of materials table with grouping and sub-totals. 

Hypertext link 

The Hypertext section has been added to the Sketch > Image command, this allows you, for example, to put a 
hyperlink on the image of a title block. 
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Bill of material index 

You can define the starting points of the arrows of the BOM indexes via the local attributes setting (as it is already 
possible to do for rich texts). 

 

Title block 

The Sketch > Text command now allows you to retrieve the document tree with or without the name and project 
tree. 

 

Scraping removal 

When several annotations or views have been modified without changing their styles, the new Restore Style 
command allows you to undo these modifications. This command is accessible from a selection of annotations in the 
graphics area or from the Entities tree. 
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Unfolding 

Performance improvement 

An important improvement regarding calculation time has been added when creating unfoldings. This improvement 
is very significant in the case of parts with many bends and/or many holes. 
Multiple unfoldings also benefits from this improvement. 

Processing parts with many bends 

A memory limitation of the software did not allow you to unfold the parts with many bends. 
This limitation has now been extended to parts with more than 100 consecutive bends. 
For parts exceeding this bend limit, a message now warns the user, suggesting that he tries to change the original face 
to balance the unfolding tree. 

 

Orient along longest length 

If this new option is enabled, an automatic rotation will be applied to the unfolding so that the longest length of its 
enclosing box (minimum) is oriented along the X axis of the destination frame of the unfolding. 

   

Example of unfolded created with 
the blue face as the selected 

reference face. 

The unfolded is oriented along this 
face without enabling the option. 

With the Orient along longest length enabled, 
the unfolded part is automatically repositioned 

along the X axis of the destination frame. 
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Work Document and Work Manager 

Templates 

When performing processes, the templates used in a work document are now copied to a Templates folder under the 
node of the generated work document. 

Various improvements 

In the list of available processes, the processes are grouped by application. 
In the Work Manager dialog box, the Undo Filters, Select All and Deselect All buttons have been added. 

 

Translators 

IFC Export 

The new Construction > Parameters > Other parameters > IFC Owner History command allows you to define the 
property information that will be exported with the IFC document. This information can be defined manually or 
retrieved from another document. 
The new Export Axis and FootPrint representations option allows you to export the axes and footprints contained in 
the representations named Axis and FootPrint. Axes are used to define the neutral fiber of the walls and the footprints 
of components such as door components. 
When an assembly contains the Type for BIM parameter equal to Simple, it is then recognized as a multi-layer material 
in the IFC file provided that the Export TopSolid Materials box is checked. 
Layers are now compatible with the new Export TopSolid Layers option. 

 

New IFC export options. 

TopGmi Import 

You can now import configurations from SolidWorks. 
In the Tools > Options > Translators > TopGmi section, the new Import as local parts option allows you to create an 
assembly document containing only local parts. When this option is checked, the assembly structure of the Step, 
Parasolid, etc. file is not kept and all the shapes, including those from a sub-assembly, are imported at the first level 
of the assembly. 
When importing a TopGmi file, the drillings are now recovered as inoperative drillings, PMIs and user properties are 
also recovered.  
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Spatial translators 

The Deep healing option has been added to the general options of the Spatial translators, it can be very useful when 
recovering poor quality STEP or IGES files. However, it can significantly slow down the file import time. 

 

Exporting exclusive sets 

When exporting a document, the Export Sets as Assemblies option allows you to create a Parasolid, Step, etc. file 
where only the structure of the selected assembly is exported. 

FBX Import 

You can now import FBX files, elements can be imported as polyhedrons or faceted shapes. 
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New export formats 

There are two new export formats: 

- GlTF export (scenes and 3D models) - File extension: .glTF, .glb 

- Redway export (3D scenes) - File extension: .red (this requires starting TopSolid in advanced mode with -a in 
the launch shortcut). 

 

Web Explorer (optional module) 

Navigation 

The project navigation dialog box has been changed to Windows Explorer, with folders on the left side of the screen, 
documents or subfolders at the top right of the screen and the dialog box for viewing, properties, references and back 
references at the bottom right of the screen. 

 

Representations 

Document representations are now available in a drop-down list at the top left of the document viewing dialog box. 
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Transparency 

You can now change the transparency of a part or a shape from the contextual menu. 

Visualization 

The Vertical Lock command has been added to the bottom of the icon bar. 

 

For tooling documents (mold, strip, etc.), specific visualization icons have been added at the bottom of the graphics 
area. 

 

Document sharing 

In the Properties tab, the Share document button allows you to copy the document URL or create an e-mail with a 
link to the document. 

About 

The About command has been added to the TopSolid'Pdm WebExplorer banner. It displays the version of the 
application, the server version and the number of available licenses. 
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This section describes the enhancements made to the Machining application in version 7.16 of TopSolid 7. 

Drilling 

Geometry search (default option) 

In the application options, you can now define the search options for similar geometries by default. 

 

Associating the MF type with the drilling primitive 

When creating a drilling operation by right-clicking on an MF, TopSolid can now recognize the MF type (tapping, 
drilling, facing) and automatically propose the appropriate operation primitive for the selected MF. 
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Cylinder analysis 

Partial cylinder management 

This new option allows you to have an additional criterion when analyzing partial cylinders whose aperture angle is 
strictly greater than the angle indicated in the Consider partial cylinders with a minimum angle field. 

 

Stack/process filter 

You can regroup the cylinders with the same machining processes in the stacks while excluding those with a different 
process from this stack. This filter is now available in the document options. 
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2D Milling 

Contour roughing 

Contour roughing is a new feature for end milling operation that allows you to machine from the outside (the stock) 
to the finished part with access to the end milling parameters. This new operation works like the classic end milling 
operation. The difference is that the selected geometry is a vertical face, which allows you to completely machine 
around the finish (similar to a side milling operation with several radial passes). 

 

End milling 

Spindle rate for final path 

In end milling operation, you can now define a spindle rate independent of the cutting conditions for the final axial 
path. 

 

Note: This new feature is also available for side milling operations. 

Coolant and delay 

As it is already possible in Boost mode, the goal is to be able to define a custom coolant for the plunge as well as a 
delay on the entire end milling strategies. 
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Retract management in HSM 

In some cases, you can force the tool to stay at the bottom of the Z pass, so as not to perform retract movements 
between the areas or different islands to be contoured. 
To do this, a Link without retraction option is now available in the HSM tab. 

 

Restriction: This option is not compatible in Boost mode. 

Z tangent clearance 

You can perform a vertical tangent retract movement at the end of the machining operation. 

 

Note: This new feature is available in the Retract tab for 2D and roughing operations. 

Last step over 

You can add or delete paths based on the value of the last step over. 

 

Side milling 

Various improvements in angle management 

- Helix mode: Shape edges followed by a "consecutive" tangent arc is now possible. 
- Truncated mode: Open profiles are better handled when using reduced contouring. 
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Boost Milling: Reversed machining feed rate management 

You can define a custom feed rate for the reversed movements of the tool path. In addition to the work mode, two 
new modes are now available when the reversed mode is activated:  

- Factor 

 

- Custom 

 

2D Machining: Various improvements and optimization 

End milling 

Bottom radius management: When the Ignore bottom radius option is checked, the finish shape management is 
maintained. 
Being able to work without a silhouette: Reduces the calculation time of the machining operations. On large parts 
(or cast parts), the time spent to calculate the silhouettes can be long. In this case, seeing that the Take into account 
the finish shape box has already been unchecked and with the TopSolid Basics default values, the calculation of the 
silhouette can be simplified. 

 

Restrictions: 

- This option does not work in open pocket and through pocket. 
- Cannot enable the Take into account the finish shape option. 
- It is also preferable to be in TopSolid Basics (default value). 

Plunge point in optimized mode: You can now define a user plunge point when performing pocket machining 
operations in optimized mode. 

Information (events): Let the default values drive the plunge type (direct, helix, etc.). If the default values for the 
plunge options are Direct and Plunge authorized and the selected tool does not have a center cut, a warning message 
will appear in the events view. 

HSM not alpha loop: Improving the remaining material removal path to avoid having loops in the path if possible. 
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Slope management: You can apply an angle offset between the Z passes to manage the incremental offset of the 
stock on the sides of the finish. This was already possible in value mode for end milling operations. 

 

Side milling: Reduce feed rate in angles 

The feed rate reduction is applied only on the angles, it was previously applied to the overlaps. 

Collision management 

The collision management options available in 3D (tool holder management) are now available for 2D operations. 

Boost Milling: Performance improvement 

Pass processing has been optimized to shorten the machining time and optimize the path when a user plunge point is 
defined. 

Slot milling 

Topological recognition of the slots and integration of the Boost mode has been improved. 

Machining features analysis: Filter and optimization 

The analysis of milling shapes is easier to use in the analysis of machinable shapes thanks to two filters that are now 
available: 

- Show features without associated method: When this filter is unchecked, the machinable shapes for which 
no machining method has been associated are no longer displayed in the list. 

- Show features without machining process: When this filter is unchecked, the machinable shapes for which 
no machining process has been defined in CAD are no longer displayed in the list. 

The use of these filters requires the use of documents external to the machining document such as the process 
document and the method/process association document. 
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Chamfering: Altitude management in wireframe mode 

You can now position the machining of a wireframe geometry at a given altitude and thus avoid touching the altitudes. 

 

Side milling: Staying at the same Z level 

You can perform a side milling operation while avoiding rapid retracts in order to reposition between each pass in Z 
as in 3D roughing. 

 

Machining features analysis using direction: External silhouettes 

The topological search for feature analysis using a direction generates a machinable outer shape by a contour roughing 
or side milling operation. 

Note: The contouring MF is taken into account in the machining features analysis. 
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Grinding 

Grinding by facing 

There is a new Grinding by facing operation. It consists of horizontally grinding the part with a “grinder" tool. This 
operation is similar to the end milling operation in Sweeping mode with a new Drift cycle. 

 

Grinding by contouring 

Similarly, you can create a new grinding by contouring operation. It consists of grinding the part with a “grinder" 
tool. This operation is similar to the side milling operation with “drift cycle" tool paths in case of open profile and 
“helix" tool path in case of closed profile. 

 

Cylindrical grinding by facing 

You can create a cylindrical grinding by facing operation. It consists of horizontally grinding the part with a “grinder" 
tool. This operation is similar to the grinding by facing operation except that the part rotates with the power axis and 
the tool always rotates in the opposite direction. 
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Cylindrical grinding by contouring 

A new Cylindrical grinding by contouring operation is now available. It consists of grinding the part with a “grinder" 
tool. This operation is similar to the grinding by contouring operation except that the part rotates with the power axis 
and the tool always rotates in the opposite direction. 

 

Creating new grinder tools 

In response to the addition of new grinding operations, tools dedicated to these types of operations are available. 

 
 

3D Milling 

Morphing: Creating points in the operation 

You can now create points directly in the operation using the selection control which will be managed by the first and 
last curve operation. 

 

Restriction: Creating sketches for the curves using the First Curve and Last Curve fields is still not compatible. 
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Dividing tool path by tool lengths: Cutting conditions management 

You can now define different cutting conditions between each cut of the path independently of the parent operation 
while dividing the path. 

Planar face machining: Geometry optimization 

As in end milling operations, the goal is to optimize the order in which the faces are made using the Planar Faces 
Machining command. By default, the planar face operation machines the faces in the order in which they are selected 
in the Geometry tab. 

Note: Changing the optimization mode changes this order. 

 

Restriction: This new feature requires that the sorting by altitude/pocket is disabled by default (useful only in case of 
additional passes). 

Material left 

Fixture management 

This feature allows you to define the fixtures directly in the operation and to take them into account. In 2D machining, 
the goal is to force the tool to go up to avoid any collision with the element concerned. 

 

Note: This option is available for all primitives in the Material Left operation. 
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Restriction: When a specific offset is applied to one or more of the fixtures, these will only be taken into account if 
they are greater than the overall value. 

 

Managing previous operations 

You can either take into account the paths of the previous operations or not as with the 3D roughing. 

 

Path management 

The goal is to manage the path during the remachining operation. TopSolid recalculates the initially calculated path 
several times with a different offset, therefore allowing the following parameters to be managed: 

Last path: Defining the distance between the last remachining path (0mm offset) and the one before it. 

 

Axial depth: Defining the distance between each path. 

 

Number of paths: Defining the number of remachining path. 

 

Restriction: We take into account the remaining material and for example, not because you ask for four paths does 
not mean that you will necessarily have four layers of tool path.  
Everything will depend on the amount of material to be remachined. 
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Roughing 

Spindle rate, coolant and custom plunge delay 

As in 2D, you can define the spindle rates, coolant and a delay between changes in spindle rotations independent of 
the cutting conditions for plunge movements. 

 

Vertical roughing: Optimized depth 

As it is already the case in 2D plunge roughing, you can manage the hollow stocks. 

 

Sweeping: Iso-parametric limitations in millimeters 

TopSolid displays the border lengths reduced to the iso-parameters defined in the dialog box. The length is displayed 
in the document unit. 
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Constant Z Finishing 

TopSolid allows you to perform a unique tangential lead-in movement during the approach. A new Tangent arc alone 
lead-in is now available. 

 

3D/5D tool path optimization: Eliminate off stock passes 

A Trim to the stock option has been added to the operations in order to eliminate all the machining tool paths that 
are not in the stock. When the path is off stock, TopSolid'Cam performs a retract to the security plane or to a direct 
link below a certain distance. 

 

Restriction: This option is only available for 3D operations that do not support roughing initially, swarf and 5-axis 
contouring. 

Roughing operations: Planar faces machining of the link 

The goal is to be able to choose the value of the link of the planar faces in three different ways: 

- Identical mode: The link on the planar faces will be equal to the global value of the link of the roughing which 
is defined in the Settings tab. 

- Custom mode: You can select a custom value different from the global value. By default, the custom value is 
equal to 70% of the tool diameter. 

- Factor mode: A percentage of the overall value will be chosen. It allows you to select a factor greater than 
100%, but at least equal to 1%. By default, the factor is equal to 100%. 
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4D Milling 

4D machining: Splitting tolerance of the rapid movements 

You can now change the splitting tolerance of the rapid movements, in order to obtain more or less points during 
rapid interpolations in the ISO output. 

 

 
 

5D Milling 

Blade machining: Simplifying dialog boxes 

In order to limit the presence of superfluous icons, the different fields in the Geometry option have been refined. 
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5X deburring  

The goal is to automatically deburr shaped parts. This process is similar to the existing 2D edge breaking operation, 
but applicable to more complex parts that can be machined in 5-axes. 

 

Port machining 

Cylindrical cavities and pipe shapes can be easily machined. 
Topological management will allow you to machine the maximum on one side then on the other once the limit is 
reached (collision management). 

 

Note: TopSolid'Cam will limit itself to the areas that can be reached (see image below) if the tool is too short or if 
the machine angular limits do not allow the entire area to be machined. 
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Turning 

Roughing: Chip-breaker delay 

You can now define a time in the Delay field, until now it was only possible to define it in Count. 

 

Note: Delay in seconds is applicable to all turning operations. 

Machining in the ZY plane 

You can work in the ZY plane for all turning operations, when the tool type allows it (tools working in the ZY plane as 
opposed to conventional tools which work in the ZX plane). The goal is to be able to work with these two tools: 

- Y parting tool: CoroCut QD (Sandvik)  
- Roughing and finishing tool: FreeTurn (Ceratizit)  

Creating turning operations is done like for a conventional tool. The operation automatically detects that it is working 
with the Y axis. The spindle directions are calculated automatically. 
Provided that the machine is capable of withstanding this cycle (in agreement with the post-processor manager), the 
ISO output, can be done in two ways: 

- Conventional WCS and tool path with ZY coordinates. 
- Rotated by 90° WCS and tool path with ZX coordinates. 

Restriction:  

- Verification in programming mode is not compatible. 
- To use these tools, you need a Y-axis on the machine. 

  

https://www.sandvik.coromant.com/en-us/knowledge/parting-grooving/pages/parting-off.aspx
https://cuttingtools.ceratizit.com/us/en/machining-know-how/turning/product-overview/freeturn.html
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Machining by interpolation 

A new feature allows you to perform Interpolation turning operations (tool path wrapped around the part). 

 

Restriction: 

- This option is not compatible for threading operations. 
- The spindle axis must be programmable. 
- The workstation must allow you to mount the turning tools. 

Steady/tail stock movement 

Chuck rotation and coolant 

The cutting conditions menu for the Steady operation has been added, giving access to spindle speed and coolant 
options, as well as a Spindle rotation direction parameter in order to indicate the spindle rotation direction, which 
defaults to None, corresponding to a stationary spindle. 
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Delay 

You can now define a delay for tail stock movements. 

 

Turn roughing: PrimeTurning™ 

There is a new turn roughing operation: PrimeTurningTM. The principle of this new strategy is to perform a back 
roughing operation. This machining technique is unique to Sandvik and is described on their website: 
https://www.sandvik.coromant.com/en-us/products/coroplus-toolpath/pages/primeturning.aspx  

 

Finishing: Extending the path to the stock 

When this option is checked, it automatically adds an overcut to the tool path to reach the end of the stock. 

Note: You can also manually enter an overcut which will be added to the automatic overcut. 

 

Restriction: The environment is not supported. 
  

https://www.sandvik.coromant.com/en-us/products/coroplus-toolpath/pages/primeturning.aspx
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Roughing: Using a cylindrical stock in machine cycles 

Some machines cannot take into account complex shape stocks in the machine cycle, so in TopSolid, we could not see 
a tool path similar to the one that the machine can take. An option has therefore been added in the parameters so 
that the calculation of the work area uses a virtual cylindrical stock that includes the real stock. 

 

Restriction: You can increase the size of this stock, but only the margins compatible with the configuration of the 
finish will be taken into account. 

 

Virtual Jog 

Feed rate movement mm/rev 

The mm/rev unit is now available for all custom feed rate movements. 
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Tools and Cutting Conditions 

Cutting conditions 

Type of operations 

In the cutting conditions documents for each specific tool, you can now define the type(s) of operation(s) such as: 
Roughing, Pre-finishing and Finishing. 

 

Ap/Ae 

In the cutting conditions documents for each specific tool, you can now define the Ap/Ae values. 

 

Note: This information is not available for drilling tools. 

Real Ap 

For the choice of values in an abacus, fixed value parameters (maximum pass depth) have been used until now. The 
real pass depth taken by the tool is often not equal to the values in these parameters. It is recalculated based on other 
parameters. The new feature consists of recovering this value and using it in the abacus. 
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Cooling pressure 

In the cutting conditions documents for each specific tool, you can define, in addition to the cooling type, the 
pressure of this one. 

 

Managing previous operations 

Previous operations are taken into account by reapplying the cutting conditions defined when creating a new 
operation. If the tool is already in use, then we can recover the cutting conditions. 

Restriction: This does not apply if the cutting conditions are provided by external elements (example: abacus). 

Application from the tool manager 

You can define the radial and axial depths as well as all cutting conditions of the tools required for machining directly 
from the tool manager. 

 

Abacus management in threading (turning) operations 

In the abacus, you can now choose the Speed ISO output, and therefore enter the spindle rate instead of the cutting 
speed. 

 

When applying in an operation, if the Speed ISO output (in turning operation) parameter exists, it will be taken into 
account. 
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Group specific mode 

Before this new feature existed, you had to create a specific abacus per tool. However, several tools can have the 
same cutting conditions. To avoid duplicating these cutting conditions per tool, a new entity has been created. 
Therefore, a new tab appears in the cutting condition document. 

 

Customized coolant and pressure 

You can create a document with different coolant associations and different pressure ranges. If a coolant document 
is linked to the machine used in TopSolid'Cam, the coolant drop-down list will only be filled with the associations 
available in the coolant document. 

Note: You can set up customized coolants in the methods. 

Restriction: These parameters cannot be modified in the machining document. If a coolant document is linked to the 
machine document, you cannot use a custom drilling document. 

In the methods, when both the coolant and custom coolant are filled in, the custom coolant takes precedence if the 
chosen association exists in the document linked to the machine. When the step format is not correct, the default 
values will be used. 
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Link Movements 

Delay 

You can now define a delay (in time or in counts) in the link movements. 

 

Copying and pasting a link movement from one operation to another 

You can now copy the link movements from one operation to another without prior backup. To do this, you simply 
have to drag and drop the source operation into the dialog box to edit the link movement of the destination operation. 
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Methods 

Managing the material side 

As is already the case with side milling operation, the choice of the material side is now available for the following 
operations: Chamfer milling, Radius milling and Side plunge. 

 

Finding work coordinate system on frame 

You can now create a work coordinate system on existing frame directly from the method document. 

 

Note: You can also select a solution interactively when performing its method if it includes an "element selection". 

Using the angular values of the work coordinate system as a comment on the operation 

This new version allows you to build an operation commentary from the angles of the work coordinate system solution 
chosen by the machining. The properties of the current solution are now available in the methods. 
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Direction management 

In the methods, the goal is to manage the Direction parameters present in the operations. To do this, the Axis 
elements are available. 

 

Optimizing geometries 

You can sort the selections automatically or manually in the method selection dialog box. 

 

Restriction: Face selection is not supported for automatic sorting. This sorting mode does not take precedence over 
any sorting criteria specific to the operations. 
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Modifying or defining the work coordinate system solution when performing methods 

You can now choose the most suitable work coordinate system solution from the list of available solutions when 
performing the method. To do this, a Use a specific solution checkbox is now available. 

 
 

Miscellaneous 

Scenario 

Colored tool change 

In the Scenario dialog box, the tool change movement now appears in a different color in order to easily differentiate 
between approaches and retracts tool changes. 

 

Tooltip on constraint 

- Constraint number: In the scenario, when you place the mouse on an operation, the tooltip now appears 
with the constraint number in the title in the <number> form. 
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- Constraint type: In the scenario, when you place the mouse on an operation, the tooltip now appears with 
the type of constraint in the title as [Manual] for manually added constraints and [Auto] for constraints added 
with a name. 

 

- Constraint name: In the scenario, when you place the mouse on a constraint, the tooltip appears with the 
name of the constraint in the title when it has been placed with the name. 

 

Tooltip on operation 

In the scenario, when you place the mouse on a constraint, the tooltip appears with the cutting conditions and the 
tool [number]. 

 

4/5-axis machining: Global security shapes 

You can define a security shape (block, cylinder, sphere, plane and direction) global to the part, so that all 4/5-axis 
machining can be based on the same shape. Based on the same principle as the security shape of the operation, these 
shapes can be defined manually or automatically. 

 

Restriction: Part security shapes can be used in an operation but cannot be modified in this one. You have to edit the 
entity directly for any modification. 
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Probing 

Probing type 

In order to dissociate the different types of machine-programmable probing and to provide the post-processor with 
the corresponding codes, probing modes have been added to all available probing primitives: 

 

- Presence of part/flange: positioning probe 
- Origin of the part: probing for the origin 
- Control report: measurement probing 

Geometry selection mode 

In order to overcome the problems of picking geometry in probing operations, the selection mode has been modified. 
A new geometry selection dialog box is now available for each probing operation. 

Probing on a sphere 

In the list of primitives, a Sphere primitive is now available. 

 

 

Environment: Hide/show 

You can now hide or show environment elements by simply clicking on the icon directly from the graphics area. 
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Working document: Generating G-codes 

A new process is now available in the work document to generate G-codes from a batch of machining documents. 

 

Shop floor documents 

Adding component variables 

The number of tool components available in the shop floor documents has been increased. As a result, three inserts, 
five assembly components and five links are now available. 
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Projecting the stock to the initial state 

You can have the initial stock in the shopfloor documents (not the final stock). This allows the operator to have a 
better view of the assembly, the adjustment on the machine and the preparation to be done. A new property is now 
available: PartInitialStockShape. 

 

View of the tool driven point position 

A symbol has been added showing the driven points used for a machining operation. The position of each driven point 
is displayed by a marker whose style can be configured (green cross in the image below) and a circle corresponding to 
the plane compensation (2D offset). 

 
 



What’s New in TopSolid’Cam 7.16  TopSolid 2022 

84   TopSolid 

TopSolid'Cam Operator 

Touch tablet or keyboard/mouse mode 

You can choose its preferred configuration, especially according to its screen, whether touch screen or not. If the 
screen is not tactile, the behavior is similar to the well-known keyboard/mouse behavior used with TopSolid'Cam, in 
particular with the contextual menu that is displayed when you right-click the mouse. 

Administrator rights management 

This allows the PDM administrator to allocate modification rights to specific parameters for each operation and 
according to the user. 

Drafting document 

A new command has been added to the machining documents displayed in the search list. This command will only be 
displayed when the machining document has drafting documents referenced to it. 

Operations tree 

The filters of the Operations tree are now available: displaying program lines, NC part lines, environment creation 
lines and displaying tool lines. 
Multi-operation modification is now possible. 
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This section describes the enhancement made to the Split, Mold, Strip and Progress applications in version 7.16 of 
TopSolid 7. 

TopSolid'Split 

Moving the Split options 

Some of the Split document options were located in the Tools > Options dialog box of the application: 
- Default colors; 
- Options for creating the stock. 

These options have been moved to the Split Blocks folder of the options of each split document. 

Selecting parting edges 

Parting edges selection picking was sometimes confusing depending on the number of selections available: tangent 
edge path, internal face loops, etc.  
A new Single edge selection advanced option allows you to manage what is offered in first selection, in this case, 
systematically the single edge hovered by the mouse. Smart selections, available from this edge, are then offered via 
rotary picking. 

Vector profile 

You can now define the length of the vector profiles by choosing to trim by plane, or by the stock planes. 
In this case, the vector profiles are certainly long enough to define surfaces entirely trimming the core cavity blocks: 
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Planar parting surface 

The behavior of the plane edge path detection has been modified to make the creation of this type of surface easier: 
- When a start edge is selected, the longest possible path of edges included in the same plane is automatically 

detected. 
- And the end edge of this path is pre-filled with the last edge of the same plane. It is always possible to restrict 

it by choosing a new end edge. 
- Now, when reversing the direction of the path, the software automatically recalculates the longest possible 

path in the other direction from the start edge, and reassigns its new ending edge. 

Automatic parting surfaces: start edge and direction of parting lines 

The calculation of automatic parting surfaces depends on the start edge in the processed parting line and the direction 
of this line. In order to stabilize the results produced by the command, this origin and direction are now determined 
in a constant manner with respect to the mold frame. 
In addition, you can now select the start edge and reverse the direction of the path. These new contextual commands 
are available by right-clicking on the list of available parting lines. 

   

Various automatic parting surface calculations depending on the start edge and the direction of the selected line. 

Shells and previews 

Calculating the sewings of each of the parting shells can be quite time consuming and each modification of options in 
this section results in a recalculation of the selected shell. You can now disable the shell creation preview so that any 
desired changes can be made more quickly in the case of complex surfaces. 
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TopSolid'Mold 

Other Set 

A new Other set category is now available in the mold. 
In addition, its viewing shortcut is available in the quick view bar. 

 

In order to benefit from this new set in a document created in previous versions, you have to launch the Recreate 
Die Sets contextual command, from the Sets folder in the Entities tree. 

Cooling and reorganizing commands 

Until now, many of the commands used in the cooling sketch were only available in the contextual menu. They have 
been grouped in a Cooling sketch section to make them easier to find in the contextual command menus. 
In addition, these commands are now all grouped at the end of the 3D sketch menu. 

 

Cooling 

A new Use Shape command available in a cooling sketch, allows any shape to be considered as a cooling positive. 
Therefore, you can create a conformal cooling after having modeled or imported this positive into TopSolid. 

The Cooling Circuit Process, Safety Margin and Collision Analysis commands in the cooling sketch, the Cooling Circuit 
Leaks and Cooling Circuit Attributes commands in the drafting also take this new type of cooling into account. 

 

Example of a conformal cooling 
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Cooling: Definition of circuit in an imported part 

Thanks to this new Cooling Shape command available in the Shape menu of a part document if the mold is installed, 
you can define a cooling circuit in the parts of a mold imported via translator in TopSolid. 
The command allows you to create a cooling positive from the faces of the cooling drillings present in the part. 
The positive is then used in the mold to create a cooling circuit and its process. Therefore, the Cooling Circuits 
Collisions, Cooling Circuits Leaks and Cooling Circuit Attributes commands can be used as if the cooling had been 
created with the "classic" cooling commands. 

 

Pins: Color the trimmed faces 

A new Color faces option is now available in the section defining the trimming options of the pins. 
If this option is enabled, the faces created by trimming the pins will recover the colors of the core cavity blocks that 
were defined when creating the parting shapes in the Split. 

  

This new mechanism can only be applied to new documents created from version 7.16 of TopSolid. 
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Pin process: Non-operable part 

When trimming a pin, you can trim it by the upper plane of the molding part that it meets at the parting plane.  
For the files created from this new version, the part, however in collision with the pin is now automatically ignored 
in the search of the targets to be operated by the process. 
You no longer have to create the process in manual mode. 

 

Marking 

Thanks to the complete redesign of the Marking command, you can now very easy to mark all parts, from the Mold 
document. You can engrave any text or a sketch, etc. as well as properties of the parts, such as the manufacturing 
indexes. 
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Pins marking 

This new command allows you to automate the marking of the pins and/or of the plate in which the pin head 
housing is made. 
By default, the command is used to mark the Manufacturing index property. However, you can choose another 
property of the pin, or a text. 
When the command is launched, the font, size and direction settings are chosen based on the first pin. These settings 
are then automatically associated to all the pins present in the mold. The positions of each engraving can be adjusted 
with each pin. 

 

Graphic cut 

A new graphic Cut command is now available in the Angle Pin, Angle Pin Pocket and Slide Joint commands. 
This command allows you to either enable a graphic cut of the mold or not to facilitate the inclusion of a pin, for 
example. It is then automatically disabled when exiting the command. 
You can configure the attributes of this cut in the options of the mold document. 

 

Slide joint 

This command has been completely redesigned in order to apply major improvements. 

- The profiles created are now simplified to the areas actually in contact between the slide and pin or corner. 
Therefore, the calculation of the kinematics becomes much less time-consuming, because as soon as the 
shapes are a bit complex, the intersection profiles are also complex, and the time to solve the kinematics 
increases. 

- You can reverse the direction of the profiles created in order to respect the direction of the material of each 
part in contact. 
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TopSolid'Strip (Strip Design) 

Drivers 

In order to facilitate the positioning of the pilot symbols on the strip, a Filter full circles advanced option has been 
added that allows you to select only complete circular edges. 

Unbending of bend 

A new Developable bend mode has been added to the command. Therefore, you can now to unroll strictly conical 
bends to create the different station shapes of the strip. 

 

 

TopSolid'Progress (Progressive Die) 

In-place punches 

The modeling tolerance set in the options of the template used to create the punch document is now used to create 
the Punch operation. 
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This section describes the enhancements made to the to the Sheet Metal Machining application in version 7.16 of 
TopSolid 7. 

2D Cutting 

Standard leads catalog 

In previous versions, a predefined and not very customizable leads catalog was available. 
From now on, the user has total freedom to create his own leads according to his needs. There are always "classic" 
leads with one or two elements (line, arc and arc + line), with the dimensional parameters.  
The user can now create more complex and hybrid lead models. These new models allow you to combine lines and 
arcs, while managing the link between all these elements with leads angles. 
The concept of a model allows you to perform a lead quickly by starting on the preset parameters in the latter. 
All these models are stored in the PDM and can be accessed from all the projects in the PDM. 

 

Standard leads catalog. 
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Management 

The Management menu has undergone a major enhancement in version 7.16. 
The success of the automatic assignments in the process relies entirely on the correct configuration of the 
management operations. Already present in version 7.15, the lead, micro-tab and cutting parameter management 
has been improved at the interface for a greater clarity. 
In version 7.16, six new management operations have been added: standard leads, cuttings management, path 
optimization, burning, drilling and checkings. 

The fine tuning of all these operations, together with the simplicity of the cutting operation and the efficiency of the 
work document, allows automation to its maximum and reduces the programming time thanks to TopSolid'Cut. 

Automated management of leads and corner cuttings 

Previously limited to one type of lead per machining document, TopSolid'Cut now offers unlimited parameterization 
of each type of lead and corner processing according to materials, thicknesses, technologies, types of contours and 
cutting qualities. 
Concerning the leads, the parameterization of these is based on the database present in the standard catalog. 

 

Leads by contour/thickness. 
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The corner processing is based on the parameters assigned in the corner processing management operation, but in a 
more advanced and customized way. 

 

Corner processing by contour/thickness. 

However, the leads and corner processing settings are not always appropriate. In order not to block the user in his 
programming, he can choose at any time not to take these parameters into account in the cutting operation. 

Processing with strategy per part or per sheet metal 

The path optimization strategies have been improved. You can now manage the cutting sequence per part or more 
generally on the entire sheet metal. In addition, other path optimization options are available: 

- At the shortest, X then Y, ZigZag, etc. 
- By type of operation (such as the one to perform the centering and marking operations on all of the parts before 

performing the cutting operations). 

All of these parameters can be very useful to avoid overheating the sheet metal while working in the same area, for 
example.  

 

Strategy per part with marking and centering. 
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Forcing lead in/out 

Each part has its own specificities in terms of topology, material, etc. Even a very comprehensive leads catalog can 
sometimes be inadequate and blocking. 
In order to avoid blocking the user, TopSolid'Cut now integrates the possibility of forcing lead in and lead out in 
several places: operation, contextual menu, etc. This possibility can be applied locally or globally to a part or a 
document. The user therefore has great flexibility in his programming. 

 

Forcing lead in and lead out in the Management menu. 

Assigning micro-tabs in sheet metal processing 

In the previous versions, the creation of machinings was only available. In order to improve the efficiency of the 
automation in the work document, you can now create and assign micro-tabs in the sheet metal machining process. 
As with the other processings, it is based on the parameters configured in the template document management 
operations. 

 

Micro-tabs in the processing. 
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Smooth links 

Machine performance is constantly evolving dynamically, with increasingly feed speeds, particularly for rapid 
movements other than cutting. TopSolid'Cut 7.16 now integrates smooth links. These make it possible to round off 
sudden changes of direction in order to reduce significant deceleration by maximizing passing speeds. 
Combined with cutting speed ramps management, and the passing points, the user can therefore control manually 
and/or automatically all the movements. 

 

 

Smooth links 

Cutting on sketch 

In this new version, you can directly select sketch entities and cut them. This command is completely transparent 
to the user but gives him a lot of flexibility. 
This allows you to add elements directly to the machining document without having to go through the part 
document. 
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Centering operation 

Among the great new features of version 7.16 is the centering operation. It is a full-fledged operation that is fully 
configurable. It can be applied both manually and automatically, on diameters but also on small internal cuttings. 
The concerned profiles will be dimensionally configured in the technology document to manage their eligibility for 
the application of the operation. Three types of centering are possible: point, diameter and cross. Obviously, each 
centering can be modified locally. 

 

Centering types 

Burning operation 

As for the centering operation, the burning operation appears in version 7.16. Unlike the previous version, it is 
considered as a preparation operation. 
Of course, the burning technology must be created beforehand in order to apply it. The user has several options to 
apply a burning: none, start point, lead and all the contours. In addition, you can assign burnings to the desired 
cuttings. However, only one type can be configured throughout the document, unlike a centering operation. 

 
Burning types 
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Drilling operation 

The drilling operation has been integrated in this new version. It can be configured to perform drilling operation 
before each cutting or to be added on all the contours of the part. 

 

Drilling 

Checking operation 

During the cycle, the losses and skeletons are likely to switch once cut and collide with the head when linking parts. 
The control operation therefore allows the user to be informed of these so-called "dangerous" links. 
Obviously, this operation takes into account the machining path optimization in order to indicate only the passages 
on the already cut profiles. These are highlighted with the dotted red lines. 

 
 
 
 
 

 
Automatic control of dangerous links 
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Entity search command 

In order to facilitate the identification and location of entities in the sheet metal machining document, a contextual 
command has been created to search for them. 
It is accessible from the Entities tree. 

 

Search entity 

Visualization command 

In the case of a nested machining document, the superposition of all the paths can overload the global visualization. 

 

Path visualization 
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5-axis Cutting 

Speed ramps 

Based on the operation of 2D operations, the management of speed ramps is now managed in 5-axis cutting 
operations. It is therefore possible for the user, depending on the topology of the part, to manage the passing speed 
in the angles independently of that of the radius. 
In addition, the levels can be set by cutting quality and thickness. You can assign different parameters depending on 
the selected entities and profiles. 
In order to easily distinguish the application of the ramp parameters, a color gradient is visible on the cutting path 
according to the speed. The color of the path will become darker and darker as the speed decreases. Therefore, the 
user can quickly check the behavior of his speed ramps on each path, without having to generate the ISO code. 

 

5-axis speed ramps 

This command is available in both 5-axis operations: face cutting and profile cutting. 
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Micro-tabs 

TopSolid'Cut now allows you to assign micro-tabs in 5-axis paths. This command takes the interface and behavior of 
the 2D micro-tabs assignment. It therefore includes the different assignment modes: manual, by contour and by 
segment. 

 

5-axis micro-tabs 

This command is available in both 5-axis operations: face cutting and profile cutting. 
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Nesting 

Manual modification 

From now on, a nesting modification command is available directly in the sheet metal machining document. This new 
command can be useful to modify a nesting without replaying it entirely, especially to optimize the gaps between 
parts and reduce the loss rate. 
But the possibilities do not stop at simple modifications. You can also delete, copy or perform a cluster nesting 
operation from one or more references. 
All modifications are made dynamically with collision management, taking into account the differences between parts 
and nesting characteristics. Therefore, the main parameters present in the nesting document are available directly 
from the machining. 

 

Manual nesting modification function. 
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This section describes the enhancements made to the TopSolid'PartCosting application in version 7.16 of TopSolid 7. 

TopSolid'Erp link - TopSolid'PartCosting 
With TopSolid'Erp 5.16, you can now import a study carried out in TopSolid’PartCosting from the ERP application. 

The import feature offers the list of parts studied in TopSolid'PartCosting from a quote, a technical quote or from 
the routings. The routing with time, material and needs are integrated into the ERP system with just one click. 
TopSolid'Erp is the only ERP application with a machining time calculation system. 
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This section describes the enhancements made to the TopSolid'Inspection Creator, Controller and Analyst 
applications in version 7.16 of TopSolid 7. 

General Information 

TopSolid'Update 

The check for updates via TopSolid'Update is launched automatically when the applications are started, and it is also 
accessible via the drop-down menu in the Connection dialog box. A link to the installation guide and update notes is 
also available. 

 

Remote configuration file 

For reasons of access rights to the C:\Program Files\ installation folder, the configuration file containing the 
Options > Global settings parameters has been moved to the C:\ProgramData\TOPSOLID\TopSolid’Inspection\7.16 
folder. The file is called "ConfigFile.Config". 

 

Only the Parameter files folder path and PDF files folder path remain in the program configuration file (by default 
C:\Program Files\TOPSOLID\TopSolid Inspection 7.16\Softwares\TopSolid.Inspection.exe.Config) and require 
administrator rights to be modified. 

OCR version update 

A new version of OCR has been implemented, it is more efficient in recognizing dimensions in image files, especially 
on vertical texts. 
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New Features 

Language selection 

In the Options > Global settings, a drop-down list allows you to choose the language. This list is automatically provided 
according to the DLL languages in the localization folders of the installation folder. 

 

The layouts files that save the layout of the lists and the custom modification of the labels are deleted when the 
language is changed. 

GDT 

The GDT standard for geometric tolerances has been implemented. In the verification dialog box and in the 
checkpoint details, it becomes possible to enter the dimension as a geometric tolerance thus enabling the pre-
provided construction system. 

 

 

The values available in the drop-down lists can be configured in the GDT1.xml, GDT2.xml, GDT3.xml files in the 
Parameter files folder path folder indicated in the options.  
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Phase management and project locking system 

Phase management allows you to flag a checkpoint as belonging to a certain stage of operation plan. This then allows 
you, in controller mode, to select the phase(s) that you wish to control and therefore to display only the dimensions 
concerned. 

An inspection project can now contain the dimensions of several phases. This development goes hand in hand with a 
project locking system to prevent several users from opening a project at the same time. The locks are stored in the 
Lock.xml file located in the same place as the other data files. 

Opening a project in Inspection Creator generates a Project lock that locks the entire project. 

Opening a phase in Inspection Controller generates a Phase lock which locks the opening of the project in Creator 
and only the phase concerned in Controller. Another controller can therefore open another phase. 

The controllers work with a partial project in memory and are able to update the original project with the collected 
data when closing. 
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CMM import 

The CMM import results from an Excel file that now allows you to use the multi-part files, the results of which are 
arranged in columns. The Import/Export dialog box now has two new The file is multi-part and The file presents 
checkpoints in columns options as well as a new Number of lines between each result field for the offset step. 
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Warning limit calculation 

When ballooning a numerical value, the warning limit calculation is carried out according to a formula specific to 
TopSolid'Inspection using a process statistics formula. Several other formulas have been added to the warning limit 
calculation: the 2 sigma mode, and several percentage modes.  
The chosen calculation formula is configured in Options > Global settings > Warning limit calculation. 

 

Please note that for a checkpoint marked GDT, the monitoring limit is calculated in 80% mode. 

First and last parts in the frequency control  

In terms of control frequency, a new setting is available that allows you to take into account the first and last parts 
to be controlled. In the example below, the controlled parts will be the first 3, then all 5 parts from index 6 (start 1), 
then the last one. 
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Moving the frame of a checkpoint 

The balloon remote control now allows you to move the frame (not the balloon) from a checkpoint. 

 

Additional balloon shapes 

Triangle and Hexagon shapes have been added as possible balloon shapes. 
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Sorting the parts to be controlled 

In the Creator and Controller programs in View by parts, the part list is sorted in ascending order based on the part 
numbers. 

     

Image on acronyms 

An image can be assigned to the acronyms in Options > List settings. The corresponding column appears in the list 
of checkpoints. 
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TopSolid'Erp - TopSolid’Inspection link 

With TopSolid'Erp 5.16 comes a close interaction with TopSolid'Inspection, driven by the ERP. 

Generating the inspection project 

From an inspection plan in ERP, the inspection project (ITL file) is automatically generated, therefore including the 
information in the operation plan. 

 

The project can be opened in TopSolid'Inspection from TopSolid'Erp to balloon the dimensions and create the 
control drawing. This is the “model” project. 
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Copying the inspection project 

When creating a PO in ERP, the "template" inspection project is automatically copied and updated with the PO 
information (PO number, part quantity, serial numbers). The quantity of part to be inspected for each Checkpoint in 
the Inspection Project is recalculated according to the quantity of part to be produced from the PO and the control 
frequencies. 
The inspection project can be opened with the Creator or Controller program directly from the ERP application. 

 

Operation with IProd 

The Inspection project is accessible from IProd for local use. It should then be downloaded to update the ERP server. 
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Synchronizing the database 

Each time TopSolid'Inspection is opened from the ERP application, the list of inspection equipment is updated on 
the TopSolid'Inspection side with the ERP items belonging to the groups attached to the Tools functional group. 

 

The acronyms are also synchronized. 
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