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Welcome to TopSolid 2021 

Throughout this document, you will discover the main enhancements and learn about the new features and benefits 
of the latest 2021 release of TopSolid 7. The innovations described here only represent a small portion of the new 
functionalities. 

If you are interested in finding out more about the newest TopSolid 2021 features, please contact your local 
reseller.
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What's New in TopSolid'Design 7.15 
  



What's New in TopSolid'Design 7.15  TopSolid 2021 

4   TopSolid 

This section describes the enhancements made to the PDM, Design, Sheet Metal, Nesting, FEA, Drafting and 
Unfolding applications in version 7.15 of TopSolid 7. 

PDM 

Multisite 

TopSolid'Pdm Server now allows you to define a primary server and as many secondary servers as there are sites. 
This mode requires a specific license, a fast Internet connection (fiber optic, SDSL, VDSL, 5G, 4G, etc.), as well as the 
implementation of a VPN tunnel between the different sites. The data is then automatically replicated between the 
different servers. 

User management 

The connection to the PDM server can now be established using the list of users defined in the Windows Active 
Directory. This simplifies the administration of TopSolid. All Active Directory information (users' last name, first 
name and e-mail address, whether or not the user belongs to a user group, etc.) is retrieved directly from the 
domain controller. 
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Sketch 

Dialog box 

In the Line, Rectangle, Circle and Arc command's dialog boxes, the radio buttons have been replaced by icons. 

    

Relative coordinates 

The End point button has been added to the 2D Sketch > Contour and 2D Sketch > Line command's dialog boxes, 
and also to the 3D Sketch > Contour and 3D Sketch > Line command's dialog boxes. 
This option allows you to indicate the end coordinates of the segment either in relation to the sketch origin, or in 
relation to the last point. 
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Offset 

The 2D Sketch > Offset command now supports the spline profiles. You no longer have to perform a sketch 
operation. However, you must check the Solving with profiles box in the 2D Sketch > Options command. 

 

Example of offsetting a profile containing a spline. 

Cells 

The new 2D Sketch > Rectangular Cell command allows you to create a rectangular profile and position it using one 
of its key points (top left, center left, bottom left, top right, etc.), in much the same way as for an extruded bar. 
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Tangency 

When creating or editing a tangency constraint, you can now indicate the tangency point. However, it must be 
selected before the second geometry. 

 

Hypertext link 

Please refer to the Hypertext link section of the Drafting chapter. 

Positioning a spatial sketch 

The Auto position when creating box has been added to the Tools > Options > Sketch section. As with a planar 
sketch, it allows you to automatically position the 3D sketch either on the absolute frame, or on the selected face. 

 

3D sketch automatic positioning option. 

In addition, when the automatic positioning options are unchecked, the question is now asked all the time, even 
when creating the first sketch of the document. 

Point repetition 

Points are now supported by the 2D Sketch > Operations > Repetition and 3D Sketch > Operations > Repetition 
commands. 
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Seedling on profile 

The new 3D Sketch > Operations > Seedling on Profile command allows you to distribute points either randomly, or 
spaced by a curvilinear length, or along a direction on a profile. The created points can be used to create multiple 
intersection profiles. 

 

Example of creating point seedlings. 

Multiple intersections 

The new 3D Sketch > Operations > Multiple Intersection command allows you to create the intersection profiles 
between a shape or a set of faces and parallel planes or guide profiles. 
The created profiles can be used to define a shape using the Surface > Fitting command. 

 

Example of creating multiple intersections. 
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Shape 

Chamfer 

In the Edges section of the Chamfer command, the Shape edges box allows you to select all the sharp edges of a 
shape. 

 

Example of a chamfer on all edges. 

In addition, the Variable Chamfer command has been added to the Shape > Other Operations menu. It allows you 
to create a chamfer by indicating different values at the ends of the selected edge. 

 

Example of a variable chamfer. 
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Angle clearance 

The new Shape > Angles Clearance command allows you to create the angle clearances of the pockets according to 
four different modes: Fillet, Chamfer, Symmetrical and On face. 

 

Drilling group 

The Shape > Drilling Group command now supports the manufacturing features (MF). 
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FreeShape 

Drillings 

In the FreeShape > Extract Drillings command, the new Extended search advanced option allows you to extract 
groups of drillings located at the same altitude but on different faces. 

 

 

Surface 

Fitting 

The new Surface > Fitting command allows you to create a surface from a set of profiles and possibly guide profiles, 
as well as passing points. The Extension section allows you to extend the resulting surface at the start and at the 
end. 

 

Example of creating a surface on a set of profiles. 
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Tangent surfaces 

The dialog box for the Surface > Tangent Surfaces command has been modified. It now takes the form of a wizard 
and the second stage of the operation in the dialog box provides options for reciprocal trimming and corner filling 
operations. The generated shapes are regrouped in a folder of the Operations tree. 

 

Selection of the face and the edges in the tangent surface creation wizard. 

 

 

Result with the corners filled. 
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Sheet Metal 

Sheet metals recognition 

Only allowed thicknesses 

In the dialog box of the Sheet Metals Recognition command, the new Only allowed thicknesses option allows you 
to consider only the parts whose thickness is available in the list of allowed thicknesses. 
You can predefine the allowed thicknesses in the Tools > Options > Sheet Metal command. 

Minimum size allowed 

The new Minimum size allowed option allows parts that could have been considered as sheet metal parts to be 
considered as non-convertible. For example, a washer with a constant thickness that is included in the list of 
thicknesses to be considered. If the minimum dimension of its enclosing box is less than the allowed one, it will be 
excluded from the list of parts to be converted. 

Identify tubes and standards profiles 

In addition to identifying the parts to be converted into sheet metal parts, the Sheet Metals Recognition command 
is now able to distinguish the parts that can be converted into tubes and/or profiles in the parts list of an assembly. 
The parts converted into tubes and profiles are automatically ignored when creating the unfoldings. 

Conversion into unfoldings 

The Conversion in Unfoldings command allows you to manage AutoCad imports containing multiple unfoldings in 
order to create unfolding documents for each part. 
Previously, performance was problematic on certain types of parts, especially the parts containing profiles with 
many segments or parts including many small, non-circular holes. The processing times have been improved in 
version 7.15. In addition, an option allowing you to clean the imported sketches is now available. 

Notches 

The new Notches command allows you to add notches on shapes, before or after converting a shape into a sheet 
metal part. 
Adding notches on parts with ambiguous modeling allows a correct recognition of the side faces, and thus a good 
conversion into a sheet metal part. 

   
Ambiguous modeling: poor recognition of 

the side faces. 
Creation of notches. The face recognition and the conversion into a 

sheet metal part are correct. 



What's New in TopSolid'Design 7.15  TopSolid 2021 

14   TopSolid 

Internal forming removal 

The new Internal Formings Removing command allows you to remove the internal formings on one face of a shape. 
In the case of non-sheet metal shapes, this simplification operation can thus facilitate the creation of a sheet metal 
by recognition. 

  
Part before removing the formings. Simplified part. The formings have been removed and frames 

have been created on one of the faces. 

Bend replacement 

The Bends Replacement command allows you to extract or replace bends on parts if the modeling of these parts is 
not perfect. This command can be applied to a sheet metal or a non-sheet metal shape. 
 

   
Part before replacing the bend. Bend replacement in Minimum mode. Bend replacement in Maximum mode. 

Ignore for unfolding 

The new Ignore for unfolding command allows you to declare the part document as to be ignored for the unfolding 
process. When the Ignore for unfolding box is checked, a parameter is created in the part document. If a part 
document contains this parameter: 

- the creation of the unfolding document by right-clicking on the part document's tab (contextual menu) 
displays a warning message and is rejected; 

- the inclusion of the part document in an unfolding document displays the same warning message; 
- the multiple unfoldings generated from an assembly that contains parts with this parameter will not display 

these parts in the list of parts to be unfold. 
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Generation of sheet metal manufacturing features (MF) 

In the Analysis stage, the Sheet Metal Properties operation now generates manufacturing features (MF) if the 

 Create MF option is enabled. 
 

 

 
 
 
 
 

The bending MFs are represented by the 
bend line and arrows at the ends on the 
sheet metal part. 

 
 
 
 
 
 

 

 
 
 
 

The cutting MFs are shown on the flat 
shape of the sheet metal part. 

A MF is created for each opening and a MF 
is created for the external cutting contour. 

 

 
 
 
 
 

The engraving MFs are shown on the flat 
shape of the sheet metal part. 
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Unfolding a mirror part 

The Mirror Part command has been removed from the Tools > Derivations menu in the unfolding document. In fact, 
it resulted in a part document, which was incorrect. 

It has been replaced by the Tools > Derivations > Mirror Part Unfolding command which allows you to create the 
mirror part of the part included in the unfolding document and to create a new unfolding document from the new 
mirror part. 

 

Unfolding and mirror part unfolding. 
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Assembly 

Extruded bars 

In the Tools > Options > Assembly > Extruded Bars command, you can now choose the command to be launched 
(Assembly > Inclusion or Modeling > Extruded Bar) when dragging and dropping an already included extruded bar 
from the Project tree, as well as when duplicating an extruded bar using the Ctrl key and dragging the mouse. 

 

The positioning and shifting handles are now placed at the ends of the extruded bar being included, while the 
rotation handle is positioned in the middle. 
By default, the shift values are kept when a new extruded bar is included. 
However, you can systematically reset these values to zero by checking the new Reset offsets during the new 
extruded bar creation box available in the Tools > Options > Assembly > Extruded Bars command. 

 

The new extruded bar handles are placed at each end of the extruded bar.  
The rotation handle is located in the middle of the extruded bar. 
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Curved extruded bars 

Extruded bar components can now be included on a 2D or 3D sketch containing curves. 
In addition, when including an extruded bar on a sketch, the tangent sections are now considered as a single curved 
extruded bar. 

 

Example of including extruded bars on a sketch with tangent sections. 

Distribution 

When distributing a component, if it is articulated, a positioning operation is automatically added so that the 
articulation can be played. 
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A margin management option has been added and is identical to the margin management of a constrained linear 
pattern. 

 

The Subcomponents button available in the First Component and Second Component sections now allows you to 
modify the length of a distributed component. 
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Inclusion with geometric drivers 

When including an articulated component, a positioning operation is automatically added so that the articulation 
can be played. If the component is not articulated, only the inclusion operation is created. 

Disassembly 

In the Modeling > Disassembly command, the new Copy Auxiliary Elements box allows you to retrieve the auxiliary 
elements from the "L-1" level sub-assembly in the "L" level assembly document. These elements are then stored in 
the Auxiliary Elements folder of the Entities tree. 

 

Decorrelation 

During a decorrelation operation, the elements hooked to the neighborhood are now basified and the neighborhood 
is deleted. 

Local part repetition 

The repetition of a local part (from a serialization for example) now results in an occurrence of the local part, which 
allows performance improvement as well as a decrease in the size of the document. 

Process server 

In order to improve performance when updating the document, the process operations for the identical 
components (same family, same code, same drivers and same processes) are performed only once. 
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Family 

Optional drivers 

The default value of an optional driver is now displayed when including the family (or the symbol). 

 

Modification 

When opening an assembly document using a modified but unsaved family document, TopSolid displays a message 
asking you if you want to save the family document. A checkbox to always perform this action is now available. 
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Bill of Materials 

Retrieving properties 

When defining a column, the new Level section allows you to retrieve a property in a higher level of the assembly's 
tree structure (Part - Sub-assembly - Assembly). 

 

Sorting 

The new Sort Frozen mode available in the icon bar at the top right of the Bill of Material menu saves you from 
updating the bill of materials when modifying the part properties. 
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Columns 

The Merge identical values box has been added to the Bill of Material > Columns command. It allows you to obtain 
a BOM table with merged cells in the drafting document. 

 
 

 

Example of a bill of materials with merged identical values in the Description and Material columns. 

In addition, when a table containing merged cells is split, the split operation can now be performed on the merged 
cells using the new Split merged cells option. 
This option is also available in the Detailing > Drillings Table and Detailing > Coordinates Table commands. 

Parameter from the assembly 

The Parameter from Assembly command has been added to the Construction > Parameters menu. It can be used to 
retrieve parameters from the assembly document, which allows you, for example, to parameterize the name of the 
BOM document in the same way as that of the assembly. 
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Workspace 

Area 

The dialog box of the Workspace command has been modified and now allows you to select 2D and 3D elements 
(sketches, frames, planes, axes and points). These elements are presented in a tree. They can also be selected from 
the graphics area or the Entities tree. 

Context 

The new Context command allows you to create contexts. Its operating principle is the same as when you create a 
set. 

 

Context management 

In the workspace background documents generated by the Workspace Manager, the operations are now clearly 
identified. 
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Visualization 

Vertical locking 

The new Lock Vertical mode locks the Z axis of the absolute frame when the view is dynamically rotated. The Z axis 
then remains collinear with the Z axis of the screen. 

 

Emissive environment 

An environment can now be defined as emissive, i.e. it will behave like a light source. It can then replace a sky light 
source. 

 

Example of an image calculated with only an emissive environment. 
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Construction 

Animate parameter 

The new Construction > Parameters > Animate Parameter command allows you to vary a parameter between two 
values and to view the animation in a separate window. 
The Point to follow and Create the curve in the document boxes respectively allow you to view the trajectory of a 
particular point and to retrieve it as a basic sketch in the document. 

 

Example of a parameter animation with curve creation (in magenta). 
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Envelope block 

The Advanced Options section containing the Create parameters box has been added to the Construction > Block 
Envelopes > Block Envelope command's dialog box. It allows you to create a length parameter for each dimension of 
the envelope block. 

 

Constrained linear pattern 

The Create parameters box has been added to the Advanced Options section of the Constrained Linear Pattern 
command. When this box is checked, all calculated values are available as parameters in the Entities tree. 
Two new Edge to edge and Thickness boxes are available in the Fixed count and Step modes. 
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Pattern modifier 

The new Construction > Patterns > Pattern Modifier allows you to define a pattern as drivable so that you can 
delete or shift one of its instances in the assembly. 
The drivable pattern must be defined in the generic document of the family and must be defined as an optional 
driver in the family document. Once the family has been included in an assembly document, the contextual menu 
called on the inclusion operation provides the Edit Pattern Modifier command which allows you to remove or shift 
an instance of the controllable pattern. 

 
 

Example of a pattern modifier. 

Point cloud 

The new Construction > Point Cloud command allows you to quickly import a point file (.pts or .xyz) into a Part or 
Assembly document. The created points are stored in the Point Cloud folder of the Entities tree. When the 
Visualization > Faceted Shape Vertex Selection mode is enabled, you can select points to take measurements. 
In addition, the point cloud entities are supported by the Visualization > Cut command. 

 

Example of recovering a point file as a point cloud. 
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Example of a cut on a point cloud. 
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Tools 

Enclosing block and cylinder 

The Margins and Round sections have been added to the Tools > Enclosing Box and Tools > Enclosing Cylinder 
command's dialog boxes. For each operation, parameters are created in the Entities tree, which allows them to be 
retrieved in a bill of materials using the Tools > Stock command (see Stock section). 

 
 

Parameters of an enclosing box. 
Parameters of an enclosing cylinder. 

In addition, these margins can also be defined according to a material using the new Box Margin Rules and Cylinder 
Margin Rules document types available in the Special tab of the document creation dialog box. These rules are then 
used by the machining modules. 

Stock 

In Manual mode, the Stock command's dialog box now allows you to associate the parameters of the enclosing box 
with the general Length, Width and Thickness parameters. 

Spare video memory 

The Spare video memory option avoids you to allocate too large video memory blocks in order to better support the 
graphics cards with less than 2 GB of memory. 
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Graphic optimization 

The Level of acceleration for drawing shapes option uses an acceleration feature available in the recent graphics 
cards. This feature can be disabled if the graphics card does not support it. 

 

 TopSolid 7.14 TopSolid 7.15 

Shading + Edges 16 img/s 27 img/s 

Shading only 19 img/s 31 img/s 

GPU occupancy (according to the Task Manager) 25% 70% 

Drilling collisions 

The Tools > Drillings Collisions command has been improved and now detects the collisions between the holes and 
the edges of the part. 
The dialog box has been simplified and the Drillings and Threadings modes have been removed. 
For the threading operations, the analysis is now systematically performed on the face corresponding to the thread 
root. 

 

Example of a drilling collision analysis with a 2mm safety margin. 
A collision is detected between the spot faced hole and the edge of the part. 
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Nesting (Optional Module) 

Automatic nesting: maximum filling 

The new Maximum filling calculation mode is available. 
For each part and in each available support, TopSolid calculates the nesting giving the lowest loss rate, regardless of 
the number of nested parts. Then it continues with the other parts by testing on the remaining supports, taking into 
account the priority of the parts and the priority of the supports. 
Only the best nesting is displayed with the resulting part quantity. 

Manual nesting 

Deleting parts and deleting support 

Two new commands are available: 

- Delete: Allows you to remove one or more parts from the nesting. 
- Delete support: Allows you to delete the selected support(s), as well as the parts nested on the support(s). 

Disable security area of parts already nested 

Thanks to the new Disable security area of parts already nested advanced option, only the security gap of the 
moved or copied part is taken into account. The gaps of the already nested parts and the support are no longer 
displayed. 

Disable collisions 

The new Disable collisions advanced option disables the collisions with the other parts and the security gaps of the 
support. A part can be moved or copied anywhere on the support. If the box is checked, the security gaps are no 
longer displayed. 

Precise positioning 

You can now choose a precise positioning to move or copy one or more parts. 
The positioning is defined by an origin point and a destination point with an X offset and a Y offset. 

Linear pattern 

The Part rotation box in the Linear Pattern section now allows you to rotate the selected part before applying the 
pattern. 

Rotations 

You can now apply a rotation to a set of parts. In the previous version, rotation could be applied to only one part. 
In addition, when the Linear Pattern box is checked, you are able, from the Rotations section, to rotate all parts of 
the pattern with the center of the enclosing box of the reference parts as the center. 

Modification 

The Manual Nesting contextual command is now available in the documents generated by the nesting document 
(assembly, machined part setup and machining documents). It is also available in the Tools menu. 
You can therefore modify the nesting from these documents. You must save the nesting document once before you 
can modify the nesting. 
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TopSolid'Fea 

Modifying the shells 

The new Analysis > Modify Shells command allows you to quickly modify the material and thickness of one or more 
shells. The shells can be selected manually or by criteria (material and/or thickness). 

Modifying the beams 

The new Analysis > Modify Beams command allows you to quickly modify the material, the profile type and its 
orientation for one or more beams. The beams can be selected manually or by criteria (material and/or family, 
code). 
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Drafting 

View alignment 

The alignment of the views has been improved: 

- The dynamic movement of an aligned view respects the alignment constraints. 
- When moving a view, all dependent views move as well. 
- The alignment constraints are displayed when hovering over a view. 

Interrupted view 

The dialog box of the View > Interrupted View command has been modified. The Standard mode has been broken 
down into two modes: 

- Manual: The interruption profiles are drawn manually. 
- Manual Standard: The interruption profiles are selected from a list of predefined types (line, wave, etc.). 

In addition, the new Automatic Standard mode allows you to automatically interrupt a view, taking into account the 
topology of the part. 

Cross section polygon 

When creating a cross section polygon, the new Like option allows you to create the same cross section polygon on 
another view as long as the directions of the two views are parallel. 
Once the polygon has been created, the Make Manual contextual command allows you to make it independent. 
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Dimensions 

The Below and Opposite to geometry text alignment modes have been added and the offset value for the vertical 
dimensions can now be adjusted. 

 

Automatic composite dimensions 

The Detailing > Automatic Composite Dimensions command now supports the views containing unfoldings. 

 

Example of automatic composite dimensions on a view containing an unfolding. 
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Automatic bending composite dimensions 

The new Detailing > Automatic Bendings Composite Dimensions command allows you to automatically dimension 
all bends of a view containing an unfolding. As with the automatic composite dimensions, the Base line, Cumulated, 
Ordinate and Continue modes are available and you can also exclude certain bends and add certain geometries. 

 

Example of automatic bending composite dimensions. 

Drilling table 

When creating a drilling note using the Detailing > Drillings Table command and the As table box is unchecked, the 
new Index all the occurrences box allows you to create a dimension on each drilling (checked box) or to create only 
one dimension by indicating the number of identical drillings (unchecked box). 

 

Example of drilling dimensions created using the Drillings Table command. 
The As table box is checked and the Index all the occurrences box is unchecked. 
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In addition, the command now supports the views containing unfoldings. 

 

Example of a drilling table on a view containing an unfolding. 

Cone note 

The new Detailing > Cone Note command allows you to create standard cone dimensions. 

 

Example of a cone note. 

BOM index 

When creating a manual or automatic BOM index, you can adjust its inclination by checking the new Angle box. 
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BOM table 

The Filter type option has been added to the Detailing > Bill of Material Table command. It allows you to display 
either the set (value with the same name) or the back references of the part (Manufacturing Index value). 

 

Surface finish symbol 

You can now place a surface finish symbol anywhere on the drawing, as long as there is a view. You can also hang 
the symbol on the arrows or the frame of an annotation. 
When the document is the GOST standard (Russian standard), if the symbol contains only the bottom text, it 
automatically adapts to the height of the text. 

 

 

ISO standard GOST standard 

Drilling notes and indexes 

The position of the drilling notes and indexes has been improved. The notes and indexes are now automatically 
positioned on the red frame of the view when optimizing the scale factor. 

  



TopSolid 2021  What's New in TopSolid'Design 7.15 

TopSolid  39 

BOM index 

The new Detailing > Magnetic Line command allows you to create a sketch on which the BOM indexes can be 
positioned by magnetization. This command is also available in contextual mode when selecting multiple BOM 
indexes. 
When moving a frame, these magnetic lines appear in yellow. You can magnetize the indexes by hovering over 
them. 
When hovering over a magnetic line, it is shown as a red axis line. It can be moved or enlarged by selecting one of its 
ends. 
A magnetic line can also be edited, like any sketch, so that it can be moved or transformed. The magnetic indexes 
will then follow the changes. 

 

Example of magnetizing indexes on magnetic lines. 
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Hypertext link 

The Hypertext section has been added in the text, note and rich text creation commands, as well as in the different 
text styles. It creates a link between a text of the document and either a PDM document, an e-mail address, a 
website, a file or a folder on the computer or network. 
You can then follow the link using the Ctrl key + double-click with the mouse (the Ctrl + click combination used in 
other applications is already used to duplicate an element). 

 

Example of a hyperlink with an e-mail address. 

Symbols 

When creating a symbol in a sketch of the 3D document using the Sketch > Other Curves > Symbol command, you 
no longer have to check the Profiles box to retrieve the symbol in the drafting document. 

Storage 

The dimensions and annotations are now arranged view by view in the Annotations folder of the Entities tree. 
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Cutting the links 

The new Edit > Isolate Drafting command allows you to cut the links between the drafting document and its 
referenced documents. 

Format 

In the GOST standard, the multiple formats (A4x3, A4x4, A3x3, etc.) have been added to the list of predefined 
formats. 

ANSI standard 

The dimensions have been modified to comply with the ANSI standard. You can now adjust the offset value for the 
vertical dimensions. 

 

For the drilling notes or any command using text (simple or rich text), you can now adjust the leader anchor point 
and the offset value from the Local attributes button. 
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Unfolding 

Parameter from a bill of materials 

In an unfolding document, the new Construction > Parameters > Parameter from Bill of Material command allows 
you to retrieve information from a bill of materials such as the quantity of parts or the manufacturing index. 

 

Work 

Document status 

In a Work document, the used documents no longer need to be checked into the vault. It is enough that they have 
been saved at least once. 

Folder creation process 

A folder creation process with a customizable name has been added. It allows you to define the name of the folder 
with the user's name and/or the creation date, as well as characters. 
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Contextual menu on assembly 

You can now create a Work document by selecting one or more documents in the Project tree or via the tab of an 
open document. For example, this allows you to select a Work document template containing processes and to 
execute them automatically if the Tools > Automatic execution box is checked in this template. 

Adding tasks by bill of materials 

In the Tasks contextual command available from a BOM document, you can now create a new Work document on 
the fly. For example, this allows you to select a Work document template containing processes and to execute them 
automatically if the Tools > Automatic execution box is checked in this template. 

Fixing a process 

When a process has produced invalid documents and failed, you can now declare it as fixed by the user thanks to 
the Declared as fixed contextual command available on the failed process. 

 

New processes 

The following processes have been added to the list of available processes: 

- Conversion into unfoldings 
- Creation of folders 
- Exports (AutoCAD, PDF, Step, Parasolid, etc.) 
- Creation of drafting bundles 
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Translators 

Spatial import 

Several enhancements have been made to the import of PMIs: 

- The Hole Feature PMIs are now converted into inoperative holes so that MFs (Manufacturing Features) can 
be produced for the machining. In addition, the drilling tolerances are automatically applied to the drilling 
operations. 

- The imported annotations are stored in sub-folders of the Entities tree. In the graphics area, hovering over an 
imported annotation highlights the referenced faces. 

 

When importing a document via a Spatial translator (Step, Acis, etc.), you can now choose to create a machined part 
setup document. 
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IFC translator 

Export 

The Advanced Options section has been added to the IFC export command. It allows you to choose the parameters 
to be exported (None, System Only or All) and to export the different classifications defined with the Tools > 
Classifying command. 

 

The single and multi-layer materials are now exported as Material Layer Set entities. 

XYZ import 

A color attribute defined with three values (RGB) is now supported for each point. 
In addition, the new Point cloud type allows you to import a point file very quickly (see Point cloud section in the 
Construction chapter). 

PDF3D export 

Line thickness management options have been added to the Tools > Options > Translators > Pdf 3d command. They 
allow you to generate a PDF document with different thicknesses for each type of line without having to perform a 
print operation (via PDFCreator for example). 

 

Adjustment of the line thicknesses during a PDF3D export. 
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This section describes the enhancements made to the Machining application in version 7.15 of TopSolid 7. 

Drilling 

Tool path optimization 

The new Optimize similar operations command allows you to optimize the tool paths of several identical (same 
primitive, same tool, same work coordinate system and same part) and consecutive hole machining operations by 
improving the paths between holes. A new master operation of the same type grouping the identical operations 
together is created under a new name. 

 

Restriction: Only the hole machinings are processed. 

Back countersinking using a reverse chamfer mill with a rigid insert 

You can now perform a back countersinking operation using a reverse chamfer mill with a rigid insert. The 
positioning parameters of the tool can be adjusted before plunging into the hole and retracting. 

 

Restriction: The double chamfer mill is not managed. 
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Counter sinking: Tool position management 

When performing a countersinking by contouring operation, you can manage the position of the tool, as is the case 
with the chamfer milling and edge breaking milling operations. 

 

Analysis of drillings and cylinders according to directions 

The analysis of drillings and cylinders now allows you to add a list of directions to restrict the analysis to certain 
faces in order to save analysis time and to filter the list of results. 
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Analysis of drillings and cylinders: Repositioning 

You can now store the already machined holes after repositioning the part. 

 

Limiting the analysis area: Associativity 

When modifying an analysis limitation area, the already created relevant drilling operations are replayed according 
to the new limitation area. 
The effect of this change only applies to the geometries available in the operation. Under no circumstances will new 
geometries be automatically added or deleted. 
Thus, these hole machining operations are able to exclude selected geometries (holes) that were previously included 
in the analysis limitation area, but which are no longer reachable after modification. 

 

Conversely, the selected geometries that were previously outside of the limitation area and that re-enter the area 
after modification are therefore included and machined. 

Restrictions: The changes in the limitations of the analysis areas do not automatically restart the analysis in the 
operations. For example, if the limitation area is enlarged to add additional holes, you will have to edit the operation 
and restart the analysis from the Geometry section. 
For holes that are outside of the area (shown in red because they are unreachable) and that you wish to remove 
from the list, you have to delete them manually. 
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Limiting the analysis area: Curves 

You can now define an analysis limitation area using bounding curves, in addition to the XYZ bounds. 

 

Limiting the analysis area: Applying a method 

Similar to what already exists in the drilling and cylinder analysis, you can limit the analysis area using the Apply 
Method command. 

 

Restriction: The selected reference face must be included in the limitation area to be able to perform the analysis in 
the referenced area. 
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Searching for identical MFs in the hole machining operation 

You can now search for the MFs (manufacturing features) of the identical holes in the Geometry option of the hole 
machining operation. 

To do this, you only have to click on the  Find geometry similar to the current one icon in the Geometry section. 
The icon is only accessible if only one element is selected in the list. 

Restriction: The stock of the part is not taken into account in the selection. The depth is that of the hole defined in 
the CAD environment. 

Management of the starting altitude in drilling/spot facing by contouring and pocketing 

In version 7.14, the safety distance affected the starting altitude of the drilling/spot facing by contouring and by 
pocketing operations, which could produce empty passes. 

In version 7.15, the safety distance no longer has any influence on the starting altitude of the drilling/spot facing by 
contouring and by pocketing operations, but it is still active for the drill cycles. 
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2D Milling 

Broaching 

Broaching is a machining process based on the use of a broaching tool (shape tool). 

The principle consists in removing the material along a slot in a strict direction, between the finished part and the 
stock, by extending it to the limits of the geometry. 

 

End milling: BoostMilling 

Custom coolant for plunge 

You can enable the custom coolant feature for the plunge in the operations using the BoostMilling strategy (end 
milling and 3D roughing). 

 

Integrated contouring 

Integrated contouring is available in Boost mode but, unlike a classic strategy, the feed rate is automatic and 
reduced on corner arcs to preserve the rate of material to be removed. 
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Path smoothing 

The path smoothing tolerates not being as close as possible to the finished shape with paths parallel to the contour. 
This reduces the abrupt changes in direction by opening the material with larger loops and reduces the variations in 
the feed rate. 
Thus, by smoothing the path, the variation of the feed rates is less important and the machine is used much less. 
However, it should be noted that for a machine that would be very fast, smoothing could have the opposite effect 
and increase the machining times. 
It is then now possible to influence this smoothing to match the characteristics of the machine to be controlled. 

 

Management of hollow stocks in vertical milling 

In the 2D contouring by plunge, pocketing by plunge and punching pocketing operations, you can now manage the 
hollow stocks, i.e. calculate plunge altitudes that are above the machining altitude as soon as the tool passes 
through the stock. 

 

Restriction: This setting is not available if the compensation plunge strategy is selected. 
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End milling: Plunge into material allowed 

The Plunge authorized option is now available in an end milling operation, as it was in the side milling operation. 
The box is checked by default for center-cutting tools and unchecked by default for non-center-cutting tools. 

 

End milling: Straight lead out in open pocket 

In order to optimize the machining paths, the end milling algorithm no longer machines around the sharp edges at 
the exit of an open pocket, where possible. 
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Number of passes for Ap 

In end milling operations, you can now select the axial path method either by number of passes or by maximum 
axial depth. This option is available in the settings or in the label of the operation. 

The number of passes is applied between the Z maximum and Z minimum of the limitation area. 

 

This option is also available for 3D roughing, swarf machining and 5-axis contouring operations. 

Breaking edge milling: Three positions 

The breaking edge milling operation provides a new Three positions method to calculate the position of the tool. 
The calculation is performed on three positions (low, normal and high) and takes the one that maximizes the 
machined length of the initial profile. 

The operation of the other two modes remains the same for the old files. Only the activation of the Three positions 
mode causes the changes. 

Breaking edge milling: Minimum/maximum values 

When performing a breaking edge milling operation, you can now: 

- enter the minimum and maximum values for the flat length (automatic chamfer selection); 
- enter the minimum and maximum diameters for the search of full circles (automatic edge selection). 
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Plunge spindle rate 

You can now define the type of spindle rate during the plunge operation. 
This option is also available for hole machining (Settings option > Drilling intersections tab) and roughing (Settings 
option > Altitudes tab > Scallop optimization box). 

 

Manufacturing Features: Pocket with islands - Island contouring 

The islands can now be managed when machining on a MF (Manufacturing Feature). For example, when islands are 
present when creating the pocket operation in the CAD environment, the corresponding MF will be able to indicate 
their presence in the CAM environment. 

Marking Manufacturing Feature 

The marking Manufacturing Feature is now included in the engraving operation. It can be selected directly by right-
clicking on the element in the graphics area. 

The marking Manufacturing Feature is also available in: 

- the methods (element selection); 
- the association documents; 
- the machining feature analysis. 

Machining feature analysis in topology mode 

The Machining features analysis command now allows you to add a list of directions to restrict the analysis to 
certain faces in order to save analysis time and to filter the list of results. Defining preferential directions allows a 
finer analysis and the detection of through pockets (bottomless pockets). 
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It is of course possible to not automatically start the analysis in order to be able to select these directions by 
unchecking the Run the analysis immediately box in the options of the machining document. 

 
 

Restrictions: 

- The analysis of through pockets is specific to the topological analysis. In MF mode, this additional analysis is 
not performed because it makes no sense: the MF fully describes each machinable shape. 

- A through cylindrical shape (through hole) is not filtered by default and is recognized as a through pocket. 
- The outer contour of the part is not recognized as a machining feature to possibly apply a contouring 

operation depending on the analysis direction. 
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3D Milling 

Constant Z performance improvement 

In a constant Z operation containing many bounding curves*, checking that these curves do not intersect can take a 
long time. Accordingly, in the case of molds for which you are sure that these curves do not intersect, you can now 
ask TopSolid not to perform any check in order to save time thanks to the new Assume no curve imbrication (quick 
computing) box. 

(*) Below 75 curves, this option is not visible because the time saving would not be significant. 

 

Avoiding collision with the conical tool shank 

Prior to version 7.15, when the collision management was enabled, the tool shank and its conical shape were 
completely ignored. Thanks to version 7.15, this conical shape is now supported. In order to correctly take into 
account the conical part, you can enter a discretization step according to the tool axis. 
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XY bounding 

In the 3D milling operations, you can now hide the preview of the XY bounds from the operation's label in the 
graphics area. 

 

You can also choose not to have XY bounds, but only Z bounds. 
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Constant Z: Compensation in the XY plane in tangent mode 

When performing a constant Z machining, when the lead in and the lead out are in Tangent Arc mode, you can now 
allow the compensation code to be sent. 
This was already possible when orthogonal lead in and lead out were performed. 

Automatic machining of electrodes or parts 

A different machining method can now be selected for each electrode when executing the automatic machining 
process in the work document. 

BoostMilling roughing finishing 

The BoostMilling strategy is now available in the roughing finishing operation. 
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4D Milling 

4-axis radial engraving 

As is already the case in the side milling and slot milling operations, you can now perform 4-axis radial engraving 
operations. 

 

4-axis radial BoostMilling 

The BoostMilling strategy is now available in the 4-axis radial roughing and 4-axis radial end machining operations. 
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Y-axis offset side milling 

When performing a 4-axis radial operation, you can now machine sides that are offset in relation to the rotation axis 
of the part. You can enter either the lead angle or the off center value. 

 

4-axis radial side milling: Helical mode 

The Helical mode option is now available in the 4-axis radial side machining operations. 

 

This mode works in the following cases: 

- with a climb milling or conventional milling direction; 
- with and without off-center; 
- with one or more passes; 
- when the profile consists of segments or arcs and segments; 
- in corrected and shifted compensation mode. 
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4-axis radial slot milling: Slope machining 

You can now perform a 4-axis radial slot milling operation using the Zigzag slope axial strategy. 

 

4-axis radial end milling: Plunge outside material 

When performing a 4-axis radial end milling operation, you can now select the Outside material plunge strategy. 

4-axis radial end milling: Wrapping lead in/lead out point 

The new Wrapping points option allows you to indicate whether the lead in/lead out point to be selected is already 
on the part (wrapped) or not. 

If the box is unchecked (default behavior), the point is projected in the WCS direction, before being wrapped. 

 

The red arrow indicates the selected point and the green arrow indicates the starting point for the machining.  
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If the box is checked, TopSolid considers that the point is already wrapped. 

 

The red arrow indicates the selected point and the green arrow indicates the starting point for the machining. 

The Wrapping points option is available in the end machining and contouring operations. 

4-axis machining using a head-head machine Automatic clearance shape 

Version 7.15 integrates a new mode to automatically calculate the clearance shapes which automatically builds the 
local clearance shape selected according to the margin defined around the part to be machined. 

 

The automatic mode is enabled by default for all new documents. For old documents, this mode is disabled and the 
already entered values are kept. 
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5D Milling 

Impeller/blisk machining 

Numerous commands have been added for the machining of impellers and blisks (blade disk parts). 

 

5-axis pocket machining 

You can now machine a pocket in 5-axis continuous mode. 

 

4-axis and 5-axis clearance shape: Clearance sphere 

The sphere shape has been added to the list of clearance shapes for 5-axis machining operations. 

 

Restriction: If the sphere is contained in the part, the tool paths will still be performed towards the sphere, which 
creates a risk of collision. It is therefore essential that you properly adjust the size of this sphere to avoid collisions. 
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Turning 

Configuring the method to calculate spun outlines 

A Turning section has been added to the TopSolid options, allowing you to configure the method to calculate the 
spun outlines for the finished part and the stock. 

 

A new Turning settings section is also available in the Options tree of the machining document. By default, the 
calculation method is the one defined in the application options. 

Preparing the revolved silhouettes 

You can now prepare several revolved silhouettes before performing a turning operation. To do this, you only have 
to select the Creation of spun outline command as many times as needed. 

 

Restriction: If a spun outline with an identical revolution axis already exists, you cannot confirm the dialog box and a 
message warns you of the problem. 
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Assembly machining 

The new version 7.15 allows the machining of assembled parts in turning. The way in which start/end faces can be 
selected has been improved so that you can select faces that do not belong to the same finish, but belong to the 
same machining part. 

 

Restriction: TopSolid does not support the case of X parts separated by a gap greater than 0.01mm in the same bar. 

BoostTurn 

The new BoostTurn strategy allows you to perform dynamic machining paths in turning operations by using a 
monodirectional or bidirectional mode. 

 

Restriction: Only tools with circular inserts are supported. 
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Using a geometrical driven point in contouring 

The objective is to allow tool path calculation with a driven point, but to drive the tool using another point. 
The new Use geometrical driven point box has been added to the finishing operation settings, allowing you to select 
a geometrical driven point. 

 

Restriction: Only tools with more than one driven point are managed. 

Customized stocks to leave 

You can now define customized stocks to leave on the faces/diameters of the finished part. The new Creation of 
customized stocks to leave command allows you to generate a custom profile from the revolved spun outline of the 
finished part. 

 

Groove roughing: First plunge retraction 

When performing a groove roughing operation, a clearance can now be automatically applied to the retraction of 
the first plunge, if possible. 
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Virtual Jog 

Improved description of virtual jog items 

Improvements have been made to the description of some virtual jog items in order to make user-defined 
information visible before editing. 

- Approach to hold part: You can adjust the approach type (stock, finish or point), as well as the shift value. In 
the case of a point, its coordinates indicated in the operation WCS are specified in brackets. 

 
Stock approach type. 

 
Finish approach type. 

 
Point approach type. 

- Part transfer: The name of the item is mentioned in the description. 

 

- Part pulling: You can indicate if you are performing a shift equal to the part length and/or enter the value of 
the simple shift. 

 
Part length shift and value. 

Enhanced ergonomics and information 

Many enhancements have been made to make sure that the information sent to the user is clearer and more 
understandable: 

- Invalidity messages: Improvement and translation of the invalidity messages displayed on the Settings icon 
of the virtual jog. 

- Turret indexing: This item no longer appears in the list of jog items when the machining document uses a 
machine that does not have a turret. 

- Rotating element: In the virtual jog editing context, selecting the rotating element triggers the automatic 
selection of the part if there are less than two parts in the document. 

- Asterisk on the Cutting conditions icon: An asterisk symbol now appears on the Cutting conditions icon to 
indicate that cutting conditions are required (when a jog item performs a feed rate movement). 

- Part selection: When editing a virtual jog operation, if the machining document contains only one part, the 
Part field of the Geometry option is automatically filled in. 

- Tool selection: When editing a virtual jog operation, if the Tool icon box is checked, the last tool used (if a 
tool is used) is selected by default. 

- Automatic WCS selection: When selecting and confirming an Approach to hold part, Part pulling or Part 
transfer jog item, the WCS is automatically created. 
Warning: The automatic WCS selection is not possible in the following cases: 

o More than one part holder that is not a "drivable part holder". 
o More than one part on the part holder. 
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Tools and Cutting Conditions 

Exceeding cutting condition ranges 

When using an abacus, you can now allow cutting condition ranges to be exceeded. 
If the Allow out of range values box is checked, you can use the abacus even if the Ae/Ap values are outside the 
defined ranges. The highest cutting speed value is taken or a cross-multiplication is applied with the next value. 
If the Allow out of range values box is unchecked, the NaN ("Not a Number" or "Not a Numeric") value is returned 
and you cannot confirm the operation. 

 

Restriction: This option applies to all abacuses in a cutting condition document. 

Specific cutting conditions of a tool linked to an abacus 

The abacus/tool readability has been improved through two options. 

In the Cutting conditions tab of the operation, a star symbol is now visible in front of the tool abacus and the 

general abacus. 

 

In addition, the name of the abacus linked to the tool is recalled when the abacus is selected. 
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Copying an abacus between two cutting condition documents 

You can now copy an abacus from a cutting condition document and paste it into another document of the same 
type. 

 

Tool catalog column filter 

As in the Tool Manager, a filter to indicate a minimum/maximum interval has been added to the tool catalog column 
headers. 

 

Restriction: The filters are not saved when closing the dialog box. 
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Advanced parameters for generic tools 

You can now choose whether or not to display the advanced parameters of the generic tools by default. This option 
can be adjusted in the TopSolid options. 

Not collapsed mode 
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Collapsed mode 

 
  



TopSolid 2021  What's New in TopSolid'Cam 7.15 

TopSolid  75 

Tool/Insert lifetime 

For both milling and turning operations, a new mode has been added to the Lifetime management command, 
allowing you to adjust the lifetime for certain operations rather than for the entire machining range. 

 

In addition, a new Steps number cutting type is available. It allows you to enter the number of steps allowed before 
considering the tool or insert to be worn out. 

 

In order not to multiply the operation lines in the NC Operations tree each time the insert is changed, the new 
Create child operations box allows you to choose whether or not to create a child operation in the machining range. 
This option is only available in insert change mode. 

 

New family of tools 

A new family of tools named High Speed Mill is available in the Tool Manager. 
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Tool magazine with a tool holder having several mounting faces (turret) 

In a machine document, the new Can grab tools in magazines box allows you to search for tools in a magazine even 
if the tool holder does not have a power axis. 

 

Restriction: The sides of the tool holder receiving the tools from a magazine must not have any tools mounted. 
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Machined Part Setup 

Margin rules for block and cylinder stocks 

In the machined part setup document, when defining the NC part, you can now determine the margins to be used 
for the block and cylinder stocks. The margin rule documents work with the dimensions of the finished part to be 
enclosed and the material used. The dimensions are automatically extracted from the selected finished part and the 
material is set in the Materials option. 

 

Restriction: You must first have created and adjusted a margin rule document (Special tab > Cylinder Margin Rules 
or Box Margin Rules). 

Show/Hide finish 

You can now show or hide the stock and the finished part directly from the graphics area. 
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Simulation and Verification 

G-code simulation 

You can now simulate the G-code generated by the post-processor in the verification phase. 

 

Speed coefficient for rapid movements 

In the simulation window, a new slider allows you to adjust a speed coefficient to be applied when simulating rapid 
movements. It is only available in simulation with time increment mode. 
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Faceting tolerance for machine elements 

In the verification configuration, you can now apply a faceting tolerance to the machine elements and 
environments. In machine mode only, the tolerance change forces you to recreate the machine, which repositions 
the simulation to the beginning (a confirmation is requested from you). 
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Link Movements 

Link movement rules 

Part/origin change 

Two new Part change and Origin change criteria are available for the link movement rules in the interoperation 
movements. The selectable values for these two criteria are Yes or No. 

 

Comparison of orientation in relation to the previous operation 

You can now compare the orientation of an axis with that of the previous operation. 

- With a value: It is always possible to compare the orientation with a fixed value. To do this, you have to 
select the Value entry from the drop-down list. 

 

- With the value of the previous operation: To be able to compare with the orientation value of the previous 
operation, you have to select the Previous operation entry from the drop-down list. 
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Program start/end 

Two new Program start and Program end criteria allow you to assign a particular link movement to start or end a 
program. The selectable values for these two criteria are Yes or No. 

 

Forcing the interoperation loading 

Thanks to the new Force loading option, you can now force the loading of the interoperation, even if there is no 
head and/or table rotation between the two operations. This option is available in the icon bar above the criteria. 

 
Restriction: This option is only available for interoperation type rules. 

PP word for link movement 

The PP word is now available in the link movements. 

 

Restriction: This menu is only accessible in Manual mode. 
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Movement along the tool direction 

A new movement named Motion along tool direction is available in the link movements, as well as in the virtual jog 
operation. It can be used in two different ways: 

- None mode: In this case, there is no automatic movement, but only a retract movement in the tool direction 
by the indicated length. 

 

- Max mode: In this case, the largest possible movement is performed along the tool direction according to the 
machine strokes. 

 

Using security shapes in the approaches 

When adding a movement onto a security element, you can choose to go to the security shape by checking the 
Force movement to shape box and thus use this shape to perform an approach. 

 

Restriction: If the tool is in the security shape, the behavior will be the same whether the box is checked or not. A 
movement is performed only if there is an intersection between the security shape and the tool axis. 
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Movement on point(s) with collision management 

In a turning link movement, you can now add a new Check collision element on point when the Manual mode is 
enabled. 

 

Restriction: We have the same limitations as the collision check in automatic mode. If collisions already exist at the 
start or end point, no avoidance point can be found. 

Editing link movements 

Saving the link movement document 

When saving a link movement document, a message tells you whether the document already exists and asks 
whether or not you want to replace it. 

Contextual menu 

A right-click contextual menu is now available on the elements in the list on the right. 
In particular, it allows you to delete, rename or show the location of an element in the Project tree. 

 
Restriction: You cannot rename or delete a link movement document that is already in use in another document 
(link movement rule document, machine document, methods, etc.). 
In this case, an error message indicates that the action is impossible and lists the documents in which the document 
is being used before canceling the current action. 
You can then make the movement obsolete so that it is no longer available in a new document. 
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Methods 

Colored hole creation in the drilling and cylinder analysis 

You can create a general method with a Hole creation action respecting the colors of the hole stack directly from 
the drilling and cylinder analysis. 

 

In the drilling and cylinder analysis, when selecting the Create hole stack method command, the colors of each hole 
of the selected stack are included in the corresponding sub-action. 

Associating methods with colored holes of a basic part 

You can now associate a method with a hole stack in the drilling and cylinder analysis if the hole colors match. In the 
Hole creation action of a general method, a new Visualization color parameter is available for each sub-action. 

 

Restriction: If a method/process association document is used, it takes precedence. 

Selecting a tool from the magazine when executing the method 

In the general method, two new parameters are available in the Select a tool function: 

- Question: Text to be displayed when the tool choice dialog box is displayed. 
- Choose tool only in document: If the selected value is Always, the function will search in the machining 

document only and/or open the tool choice dialog box. 

 

In case of manual tool selection, it will also be possible to filter the results via the Tool Manager. 

Restriction: The Pocket parameter is ignored. 
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Copying and pasting operations in the same machining document 

To copy operations in the same machining document, you should always use the Copy operation that copies 
everything, including the machined geometry. 
The new Paste graphically command allows you to paste the operations by selecting one or more new geometries. 

 

Copying and pasting operations without geometry selection 

After performing a classic copy and paste operation of a machining range between two documents, you no longer 
have to select a geometry when a question relating to the method is asked. You can proceed to the next step even if 
no geometry is selected. The following question is then displayed. 

 

Adjusting the tool's machining pocket 

In the machining pocket search action, the new Machining pocket parameter allows you to search for the tool only 
in machining pockets. 
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Using the default value set 

When defining a method, you can choose whether or not to use the default set of values for machining operations 
when creating the machining action or when executing the method. The method is then associative with the default 
values. 

 

Search for edges and chamfers 

A new Find breaking edge(s) function is available in the Find category. It allows you to provide geometries for the 
breaking edge milling operation (equivalent to the Generation of geometry option in this operation). 

 

Restriction: The search result can only be used by the breaking edge milling operation. 
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New analysis functions in the methods 

In the general method, two new Analyze for drilling and Analyze for end milling functions are available. 

 

These functions are capable of analyzing all types of geometries that can be machined by drilling and end milling 
operations. 

Analysis of an element length 

In the general method, the Length variable has been added to the Analyze element action. It returns the length of a 
2D or 3D profile, segment or edge given by the Find elements or Picking elements actions. 
 
Restriction: This is only available for profile, segment and edge elements. If the element is of another type, the 
length will be 0. 
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Miscellaneous 

Machining inside a part: Managed Z bounded plane for the stock and finished part 

To machine inside a part, you can define a cutting plane, i.e. a plane resulting from the defined work coordinate 
system with an altitude. This plane allows you to cut the shapes (stock, finish, etc.) and to avoid finding collisions 
that forbid the machining or altitudes that are too high. 

Accordingly, two new parameters have been added: 

- Tool holder in the part (which allows machining inside the part) 
- Altitude of free plane 

 

Inclusion property 

A new Machinable user property is available in the TopSolid Machining library. It avoids displaying the dialog box 
asking whether the included part is to be used for an NC part or a normal inclusion. 

 

Exiting the "Show machine preview in position" mode 

When creating or editing a machining operation, when calling up a command to create an entity (point, profile, 
sketch, etc.), the preview of the machine in position pauses and the machine is displayed in the rest position to 
facilitate the selection. 
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This section describes the enhancements made to the Split, Mold, Electrode, Strip and Progress applications in 
version 7.15 of TopSolid 7. 

TopSolid'Split 

Performance improvement 

Version 7.15 offers significant improvements in terms of software performance, especially in the TopSolid'Split 
module as it relates to the processing of very large and geometrically complex parts: 

- Launching the Parting Edges command: 90% time saving. 
- Creating the shells: 40% time saving. 
- Improving calculation time of the core cavity blocks when the dialog box opens: 30% time saving. 
- Improving calculation time of the insert surfaces created using the Faces mode: 75% time saving. 

Pre-study mode 

The core cavity blocks created in pre-study mode now include the shapes to split. You can still choose to split the 
stock using the opening plane in order to create the two core cavity blocks via the options in the Split Blocks 
document. 

Improved candidate edge detection 

The way in which candidate edges can be detected has been improved, especially for the parts with grids. 

Parting edges 

Number of shells 

The number of shells obtained after each parting edge operation is now displayed in the Operations tree. It is also 
indicated that the operation creates no parting in the case where you have selected edges that does not allow the 
part to be split into at least two shells. 

 

Edge path between vertices 

The new Edges Path between Vertices command helps you to create parting edges and is available via the  icon 
in the Parting Edges command. It identifies the shortest parting edge path between two vertices on the part. You 
can calculate this path by forcing it to pass over the selected edges. 
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Extension parting surfaces 

A new Tangent mode is available to create lateral extensions on the Extension parting surfaces. 

 

Automatic parting surfaces 

The creation of automatic parting surfaces has been greatly improved: 

- The calculation time has been optimized (from 50% to 80% time saving according to the type of part). 
- The results are much better. 

  
Automatic surfaces produced in version 7.14. Automatic surfaces produced in version 7.15. 
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TopSolid'Mold 

Pin preview 

Positioning many pins simultaneously in sketch mode in a large mold file can be quite time-consuming. 
In order to avoid calculating the preview of each pin, you can now enable or disable the preview in this positioning 
mode. 

 

Cooling 

Creation on existing 3D sketch 

You can now create cooling circuits on 3D sketches, which offers many new options: 

- standard cooling circuits based on sketch components; 
- symmetrical repetition of a circuit by repeating the sketch; 
- repetitions of segments within the sketch; 
- associativity between the sketch and the cooling circuit. 

Preferred entry faces 

You can now consider certain faces of the part as the entry faces of the drillings created by the cooling sketch. 

  
It might have been interesting to create the  

blue drilling in the other direction. 
The drilling is automatically oriented  

by defining an entry face to the circuit. 

Baffle line point 

The new Baffle Line Point command, which is only available in a cooling sketch, simplifies the creation of baffle 
lines. A baffle line is automatically performed for each created point, as you defined it in the cooling style. 

Offset 

The new Offset option has been added to the Modify components command in a cooling sketch. It allows you to 
modify the offset of the selected components. 

Angle pin 

You can now create a parameter corresponding to the real stroke of the angle pin when including each angle pin. 
The parameter is named Stroke - Ange pin inclusion operation name. 
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Drilling collisions 

The Drillings Collisions command has been completely redesigned to be able to test for collisions between all the 
drillings available in all the mold's parts, whether the drillings are performed by an operation in the mold or whether 
they were created locally in the parts. 

This command automates the launch of the Drillings Collisions command available in any part document: 

- You do not need to open every part. 
- This allows the different collisions identified in each part of the mold to be grouped in the Drillings Collisions 

folder of the Entities tree. 
- The collisions between the different cooling drillings are automatically excluded. 

Mold simulation 

Ejection stroke parameter 

The new Ejection Stroke Parameter command makes it easy to create an ejection stroke parameter based on the 
parts and blocks included in the mold document. Several calculation modes are available. 

   

Inferior and superior blocks extremities 
mode. 

Part and superior block 
extremities mode. 

Part extremities mode. 

This stroke can then be selected to calculate the mold simulation. 

Open tooling configuration 

The new Open tooling configuration option allows you to create and maintain a configuration of the tooling in open 
position. This option is useful for controlling the mold design. 

In particular, you will be able to easily test the collisions in open position thanks to the Configuration Collisions 
command, as you will be able to copy this configuration in order to modify the joint driving values to test the 
collisions in different positions of the tooling. 

Decorrelation 

You can now decorrelate a mold. The Decorrelate command allows you to basify the links between the mold and 
one or more of its synchronized documents. All entities referencing an entity in another document are replaced by a 
basic entity. 

At the end of the mold design and before editing it and put it into production, this operation allows you to manage 
independent life cycles on each part and also allows you to modify a mold very locally without impacting all the 
other parts of this mold. 
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TopSolid'Electrode 

Drilling detection 

The Drillings Detection command has been significantly improved in terms of performance, with time savings of up 
to 75% compared to the previous version of TopSolid'Electrode. 

Removing cooling circuits and drillings 

The Removing Cooling Circuits and Drillings command has been significantly improved in terms of performance in 
the case of hole removal. Time savings of up to 50% compared to the previous version of TopSolid'Electrode can be 
achieved. 

Shells 

You can now select several holes to be filled simultaneously. The unclosed openings can also be automatically filled 
in the simple cases. 

 

When the faces connected to the edges of the holes to be filled are not in the plane of the hole, you can shift the 
created face to fill the hole. The connected faces will be extended. 

  

Filled hole. 
Filled hole with shift. 

Eroding shape 

In the Eroding Shape command, the new Total height information indicates the height of the eroding shape that will 
be generated when confirming the command. The height is calculated according to the given extension direction. 

In addition, the new Blend edges option allows you to automatically add fillets onto the blend edges between the 
first and second extension. 
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Orbital 

A new Translated creation mode is available and can only be applied to orbital electrodes with a revolved shape. In 
this mode, the undersizing is applied by translating the silhouette of the eroding shape. 

 

Electrode 

Dimensioning origin of the EDM frame 

When creating an electrode or including an electrode in the Electrodes document, you can now select the 
dimensioning origin frame. 
Therefore, regardless of the electrode's diving direction, you can determine its position according to a frame you 
have selected. 

Base orientation 

The base orientation can now be defined in two ways: 

- Eroding shape direction: The Z direction of the base corresponds to the direction of the last extension of the 
eroding shapes. 

- Positioning origin direction: The Z direction of the base corresponds to the Z direction of the positioning 
origin. 

  
Eroding shape direction. Positioning origin direction. 
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Total height 

For the electrodes created from version 7.15 onwards, you can create them by indicating their total height. 

Depending on the given total height, two adjustment modes are available. 

  

The height of the head is adjusted to create an electrode of the 
desired total height. 

The total height and the head height are given. 
The height of the eroding shape is automatically adjusted. 

Height of the base in relation to the shape to be eroded 

A new dimension is visible in the electrode creation preview. This informal dimension is displayed in the color of the 
preview. It allows you to easily view the minimum height between the electrode base and the shape to be eroded. 

Blend edges 

You can now automatically add fillets or chamfers to the blend edges between the base and the eroding shape. 
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Automatic detailing 

When creating the electrode, the new Detailing advanced option allows you to automatically create the detailing 
dimensions of the electrodes in the drafting documents. You also have to check this box in the views of the drafting 
templates to benefit from this automation. 

 

Creating frames on the fly 

Thanks to the  icon, you can now create the following elements on the fly: 

- An additional origin frame as the dimensioning origin in the Electrode and Include Electrode commands. 
- A frame as the positioning origin of the electrode base in the Electrode command. 

Removing eroded faces 

Detecting eroded faces by the theoretical electrodes did not take into account the possible modifications performed 
on the area to be eroded when creating the shell of the original electrode. 
The Removing Eroded Faces command has been enhanced and now allows you to better identify the eroded faces 
to be removed and to automatically perform the removal operation as it was defined by the original electrode shell. 

Electrode occurrence properties 

The occurrences of an electrode are its theoretical positions. The new Electrode Occurrence Properties allows you 
to assign different properties to these occurrences, e.g. a number of electrodes property for each occurrence. 
These properties can then be displayed in a drafting document and/or an electrode table. 
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Eroding area properties 

The new Eroding Areas Properties command is used to calculate the projected area of the silhouette and the sum 
of the face areas of the eroding shapes defined for each electrode. The calculation is performed in the Analysis 
stage of the document. The properties will only be updated after switching the document to this stage or after 
saving the document. 

Created in the electrode's part document in the Analysis stage, the properties can be used in the electrode tables 
and electrode notes. 

 

Electrode drafting 

Projection set 

You can now add the initial positions of the electrodes to 
an Electrodes projection set. The initial positions can 
therefore be projected in the drafting documents. 

Initial positions 

The new Initial positions option allows you to add in the 
views the occurrences of the electrodes in initial position. 
If the initial positions are projected, they are annotated by 
the Automatic Electrode Note command. 

 

Electrode table 

In the Electrodes Table command, the new Sort by electrode name advanced option allows you to sort the 
electrodes alphabetically in the table. If the box is unchecked, the electrodes are sorted in the order in which they 
were created. 
The following two sorting modes are available: Ascending sort and Descending sort. 
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TopSolid'Strip (Strip Design) 

Unstamping Materials 7.14 library 

A new material library named Unstamping Materials 7.14 is available on 
TopSolid'Store. 

www.store.topsolid.com 

This library contains examples of materials for FTI simulation. 
In an Unfolding or Strip Design document, if the unstamping operation is 
performed on a part with a partially completed material, TopSolid completes the 
mechanical characteristics of the material with values corresponding to the steel 
values. 

The decision was made to share this library via TopSolid'Store and not via the 
software installation since we cannot guarantee the accuracy of the data and 
simulation results. 

Station shape management 

Two new Basify station shapes and Basify cutting operations sketches options are available in the Advanced tab of 
the Station Shapes Management command. 
In order to lighten the strip file and simplify its design, you can now basify all the station shapes and punching 
sketches. 

The operations performed on the shape to strip are not deleted. To further simplify and lighten the file, they can be 
deleted in the station preparation stage.  

Following the basifying operations, any changes to the strip design must be made directly on the station shapes that 
are grouped together in the Stations Preparation Shapes set of the Entities tree. 

Derived strip 

In a strip design document, the Tools > Derivations > Derived Part command now generates a Strip Design 
document. Using this command can be interesting if the calculation of the merged strip and the strip properties is 
quite time-consuming. 
In the "work strip", you can delete the two Merged Strip and Strip Properties Management operations, and then 
create the derived part from the strip. The Merged Strip and Strip Properties Management operations must then be 
recreated in this document. It will then be possible to update the derived document in a desynchronized way when 
it is opened. 
The original document should be used to create the progressive die and the derived strip should be used for the 
strip drafting. 

 

  

https://store.topsolid.com/
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TopSolid'Progress (Progressive Die) 

Pilots 

The pilot symbols included in the Strip Design document are transferred when including the strip in the progressive 
die document. 

Angle clearance 

The Angles Clearance command is now available in the Shape menu of the part documents and no longer in the 
Progressive Die menu. 

Two new selection modes available via the  icon make it easier to select edges: 

- Pocket Edges from Loop 
- Pocket Edges from Face 

  
Pocket edges from loop. Pocket edges from face. 

Progressive die simulation 

In the Progressive Die Simulation command, the new Create an open tooling configuration box allows you to 
create and maintain a configuration of the tooling in open position. This option is useful for controlling the 
progressive die design. 

In particular, you will be able to easily test the collisions in open position thanks to the Configuration Collisions 
command, as you will be able to copy this configuration in order to modify the joint driving values to test the 
collisions in different positions of the tooling. 
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This section describes the enhancements made to the Sheet Metal CAM application in version 7.15 of TopSolid 7. 

2D cutting 

Automatic cutting 

The new Automatic Cutting command allows you to automatically assign cutting operations to several elements or 
parts simultaneously based on the parameters adjusted in the management operations (leads, micro-tabs, and 
cuttings). You can also modify these parameters directly in the dialog box of the operation. 

You can select different types of elements: parts, contours or cuttings, etc. 

 

Automatic cutting. 

For the operation to run smoothly, the management operations must obviously be correctly pre-configured. 

You can edit the automatic cutting operation after confirming it without deleting it completely by using the various 
editing commands available in the Cutting menu. 
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Partial profile cutting 

The partial cutting feature is now available in the 2D cutting operations. This allows you to freely cut out a section of 
the contour. Indeed, either the starting points are anchored on specific sections of each entity (corners, middle, 
etc.), or you can position the points dynamically, as needed, by moving the mouse cursor. The advantage is to be 
able to optimize the tool path, especially in the case of a common cutting operation occurring later in the cutting 
cycle. 

 

Partial profile cutting. 

Corner processing 

The new Corners Processing option allows you to place geometric entities at specific locations on the tool path. 
These entities are geometrically parameterized to increase the curvatures and decrease the breaks in the tool path. 
More specifically, the interest of this new feature is to optimize the dynamic behavior of the machine by reducing 
the accelerations and decelerations which can generate important mechanical stresses on the axes. This improves 
the quality of the part cutting. 

 

Corner processing in looping mode. 
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Nesting 

Unit part 

The new Unit Part command, which is available in the Nesting menu, has been developed to be able to generate 
safe machining in an extremely fast and efficient way. This command can be very useful in the case of a test part, 
before starting to cut a complete series of parts. 

 

Dialog box of the Unit Part command. 
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Process automation 

Work document 

The Work document allows you to generate several processes automatically. It is based on template documents that 
are parameterized according to the machines, materials and production types. There are many processes available: 
unfolding, machining, nesting, drafting, etc. 
Once all the templates have been adjusted, you only have to insert the parts to be processed and the available 
supports as well as select the processes according to your needs. 

This document is very useful if you want to improve your efficiency. It meets the requirements of high-volume 
production by allowing the automatic generation of documents in hidden time to be optimized, and also by 
structuring the location of these documents in the current project. 

 

Work tab 
 

 

Processes tab 
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Process result 

Work Manager 

The Work Manager is a scheduling tool that allows you to manage a workflow in a simple, efficient and orderly 
manner. It can be adapted to documents of different types: CAD (drafting, bill of materials, etc.), CAM (machining, 
nesting). 

In addition, a number of settings and filters allow tasks to be scheduled according to the company's habits. The 
customer can therefore choose his scheduling order by material, thickness, part family, etc. 

In PDM server mode, you can also assign tasks to several users and thus distribute the workflow within a team. 

This tool is an additional complementary step to the work document by combining automation and management. 

 

The Tasks tab listing the tasks to be distributed. 

 

The Works tab grouping the works to be managed. 
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